Closed Bug 515277 Opened 11 years ago Closed 4 years ago

When opening compose window, initially flashes last opened compose window

Categories

(Thunderbird :: Message Compose Window, defect, minor)

x86
Windows 7
defect
Not set
minor

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1046207

People

(Reporter: benaneely, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.1) Gecko/20090715 Thunderbird/3.0b3

This is a consistent problem, and not one that I would label serious, but might indicate a simple issue.  When I open a new compose window, I immediately see the last compose window I had open, for a split second, and then a fresh window is visible.  So, if I had just wrote an email to my boss and then send it, and go to write another email, I briefly see the message I just wrote before it turns into a fresh window. This is also true if I close a blank compose window and then open a new one; in that case, i just see to fresh compose window flash and then the new one. 

Hope this helps.

Reproducible: Always

Steps to Reproduce:
1.Open new compose window
2.Watch as window opens for brief flash
3.
Actual Results:  
See details.

Expected Results:  
Not flash a previous window.
Severity: normal → minor
Version: unspecified → 3.0
we cache composed windows, to avoid the cost of building them up every time - that's probably at the root of this issue. We should be clearing out the contents of the compose window when we pseudo-close it, not when we re-open it, I would think.
Status: UNCONFIRMED → NEW
Ever confirmed: true
I'm experiencing the same issue and it could lead to a small privacy problem imho, in addition to not being nice visially.
When using TB at work, I compose private and work mails. But I wouldn't want a colleague to be able to read the possibly private previous email, watching over my shoulder when working together.. :)
Thanks
This is due to the window recycling. This will be removed soon.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 777732
It seems like fixing Bug 777732 would fix this one, but "soon" can be years around here and the symptom described is more like Bug 1046207, which could have other solutions too.
Duplicate of bug: 1046207
You need to log in before you can comment on or make changes to this bug.