Converting some features to Mozilla-maintained extensions (installed by default) would restore original selling point of Firefox and make it more convenient for power users

RESOLVED INVALID

Status

()

Firefox
General
--
enhancement
RESOLVED INVALID
9 years ago
9 years ago

People

(Reporter: 205a7679, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.2) Gecko/20090818 Shiretoko/3.5.2
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.2) Gecko/20090818 Shiretoko/3.5.2

When Firefox 1.0 was released, the declared goal of Firefox was to be a small and extensible browser. This was proposed as a design decision opposite to Mozilla Suite, which had a lot more features out of the box (but also had stability and resource consumption troubles).

Later, attention was paid to discoverability and out-of-the-box functionality. Some functionality provided by the best extensions was merged into the default Firefox UI. Most (but not all) this functionality can still be turned off in about:config.

In the result, Firefox browser looks more bloated with each release (and Gecko improvements make staying with an old release very unattractive - and insecure - option). While easy access to the new functionality is good, this usually leads to extinction of competing ways to do the same thing in better ways (maybe partly because overriding defaults in browser.jar is harder). 

Would it be better to have some parts of functionality as extensions installed by default? For example, some people argued against Awesome Bar, and the mere possibility to disable it as extension (with all the warnings and taint flags in browser ID) would be very nice. The same goes for malware site alert (which seems to be turned off by noticeable part of power users, but probably still sits in the memory). Another kind of example is the download dialog, where default dialog may be the best for many people, but could be replaced with DownThemAll for some other users. 

If I am wrong that most of the actual code used for extension and for in-browser implementation is just the same, this, of course, becomes an invalid feature request.. I also do support default installation of these extensions and taint flags if these extensions are disabled (i.e. bug reports with disabled default extensions could be separated just like currently bug reports with installed buggy extensions are).

It looks like some medium-weight browsers (e.g. Midori) do have some core functionality implemented as extensions installed with browser.


Reproducible: Always
This is invalid for more than one reason:

- One issue in one bug and for example the moving the Malware protection would be one bug and the awesomebar would be another.
- This is not a request for a new feature, it's a request for removing features
- Discussion about such general things doesn't belong into bugzilla, use the newsgroups.
- Do not assume that if you dont need a feature like the Malware protection that not nearly every other user wa´nts this feature as core feature in FF.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

9 years ago
Thanks a lot for detailed comment and for recommendations.

I would like to point out, that it is not about removing features from the shipped installs - only about making easier to remove them. Of course, this filing is still invalid for the rest of reasons. Sorry for inconvenience.
You need to log in before you can comment on or make changes to this bug.