http://www-archive.mozilla.org/releases/ should be added to www.mozilla.org for control downloads

RESOLVED WONTFIX

Status

www.mozilla.org
General
--
major
RESOLVED WONTFIX
9 years ago
6 years ago

People

(Reporter: Andstar, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2 (.NET CLR 3.5.30729)
Build Identifier: 

http://www-archive.mozilla.org/releases/ should be added to www.mozilla.org for the ActiveX control downloads.

Reproducible: Always
I have no idea what "ActiveX control downloads" are, but the page you want to include on mozilla.org discusses releases from 2006. We have no intention of restoring it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 2

9 years ago
(In reply to comment #1)
> I have no idea what "ActiveX control downloads" are, but the page you want to
> include on mozilla.org discusses releases from 2006. We have no intention of
> restoring it.

If you are a Visual Basic coder then you'd know what an ActiveX control is and how to use it. This page contains downloads that can allow Visual Basic coders to use the Mozilla browser control in their application. Only by restoring this page and updating it can the Firefox browser be truly Open-Source.
Status: RESOLVED → UNCONFIRMED
Resolution: WONTFIX → ---
There is nothing on that page related to ActiveX or Visual Basic. If there are recent downloads that should be posted somewhere, I recommend developer.mozilla.org. We will not be restoring this page.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago9 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 4

9 years ago
(In reply to comment #3)
> There is nothing on that page related to ActiveX or Visual Basic. If there are
> recent downloads that should be posted somewhere, I recommend
> developer.mozilla.org. We will not be restoring this page.

OK, then where would I be able to get an updated version of the downloads on this page: http://www.iol.ie/~locka/mozilla/control.htm, "Get the binaries". These downloads were from the site in the summary.
Status: RESOLVED → UNCONFIRMED
Resolution: WONTFIX → ---
Moving this to MDC, where it will likely be WONTFIXed since we shouldn't ever be linking to old builds of anything, certainly not Mozilla 1.7.x-age releases...
Component: www.mozilla.org → Documentation Requests
Product: Websites → Mozilla Developer Center
QA Contact: www-mozilla-org → doc-request
I had some trouble understanding this bug, but after reading it over, I think I understand now. Please correct me if this is wrong:
Andstar is a visual basic coder, that wants to test an ActiveX control in Mozilla. He went to Adam Lock's website in search of Adam's ActiveX Control for Mozilla plugin. On Adam's website, it says something to the affect of "You need Mozilla for this plugin to work. Here's where to download Mozilla (which points to <http://www.mozilla.org/binaries.html>." And that URL redirects to the releases page. So Andstar wants the releases page back on www.mozilla.org, so the link on Adam's site will work.

Andstar, is that correct?
(Reporter)

Comment 7

9 years ago
(In reply to comment #6)
> I had some trouble understanding this bug, but after reading it over, I think I
> understand now. Please correct me if this is wrong:
> Andstar is a visual basic coder, that wants to test an ActiveX control in
> Mozilla. He went to Adam Lock's website in search of Adam's ActiveX Control for
> Mozilla plugin. On Adam's website, it says something to the affect of "You need
> Mozilla for this plugin to work. Here's where to download Mozilla (which points
> to <http://www.mozilla.org/binaries.html>." And that URL redirects to the
> releases page. So Andstar wants the releases page back on www.mozilla.org, so
> the link on Adam's site will work.
> 
> Andstar, is that correct?

Close to it.
Andstar is a visual basic coder, that wants to test an ActiveX control in a program he is making. On Adams website is the ActiveX control of which Andstar can use in his program, but there is something wrong. Andstar is getting an error saying something along the lines of: "Unable to get the window handle for the 'AxMozillaBrowser' control. Windowless ActiveX controls are not supported." So Andstar is trying to get an update to these controls or for the page to be restored for everyone. Unless someone can help him fix the error he is getting. Also Andstar is using Visual Studio 2008 while the control is meant to be used in Visual Studio version 6 but he is unsure if it works for others. ;D
Hi Andstar,
I'm not sure if this is clear to you, so I'd like clarify that Adam's plugin is not developed within the Mozilla project. That's Adam's code. In addition, if Adam's website is out of date (and I know that he hasn't updated it in years), then you need to contact Adam.

More importantly, Mozilla has never supported ActiveX controls; so I'm puzzled as to why you want to test it on Mozilla.
See <http://support.mozilla.com/en-US/kb/ActiveX>.
(Reporter)

Comment 9

9 years ago
(In reply to comment #8)
> Hi Andstar,
> I'm not sure if this is clear to you, so I'd like clarify that Adam's plugin is
> not developed within the Mozilla project. That's Adam's code. In addition, if
> Adam's website is out of date (and I know that he hasn't updated it in years),
> then you need to contact Adam.
> 
> More importantly, Mozilla has never supported ActiveX controls; so I'm puzzled
> as to why you want to test it on Mozilla.
> See <http://support.mozilla.com/en-US/kb/ActiveX>.

Ok, thank you very much for verifying this for me. I have only one last request... Do you know how I could contact Adam Lock?
Try the info at <http://www.iol.ie/~locka/mozilla/mozilla.htm#contact>. If that doesn't work, I don't know.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago9 years ago
Component: Documentation Requests → www.mozilla.org
Product: Mozilla Developer Center → Websites
QA Contact: doc-request → www-mozilla-org
Resolution: --- → WONTFIX
(Assignee)

Updated

6 years ago
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.