[10.6] Window loses focus on Growl notification in 10.6

VERIFIED FIXED in Firefox 3.7a1

Status

()

VERIFIED FIXED
10 years ago
10 years ago

People

(Reporter: danne.da, Unassigned)

Tracking

({verified1.9.2})

Trunk
Firefox 3.7a1
All
macOS
verified1.9.2
Points:
---

Firefox Tracking Flags

(status1.9.2 beta2-fixed, status1.9.1 unaffected)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.3a1pre) Gecko/20090909 Minefield/3.7a1pre
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.3a1pre) Gecko/20090909 Minefield/3.7a1pre

When a Growl notification appears the Window loses focus. It doesn't happen always but seem more likely to happen on the first Growl notification in a browser session. Seem to be related to bug 510740.

Reproducible: Sometimes

Steps to Reproduce:
1. Start Firefox
2. Wait for Growl notification to appear or force notification to appear (Tab Mix Plus - F9 key, ForcastFox - update weather data will cause growl notification)

Actual Results:  
Window loses focus.

Expected Results:  
Window should keep focus when a growl notification appears.
(Reporter)

Comment 1

10 years ago
YouTube video of this: http://www.youtube.com/watch?v=9lQ4jf5Tpdo
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 510740
Looks as if https://bugzilla.mozilla.org/show_bug.cgi?id=510740#c47 indicates it is fixed on the trunk, so if you are seeing it after the date it landed then it must be a different bug.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Status: UNCONFIRMED → NEW
Ever confirmed: true
Has anyone tried to reproduce this in other browsers -- like Safari?

Detailed steps to reproduce would also help.
If you haven't upgraded to 10.6.1 please do so.  And let us know if this fixes the problem.
> If you haven't upgraded to 10.6.1 please do so.  And let us know if this fixes
> the problem.

I've just tested for bug 510740 on OS X 10.6.1 with FF 3.5.3 (which doesn't yet contain the fix for bug 510740.  Bug 510740 still happens, so OS X 10.6.1 didn't resolve it.  So presumably 10.6.1 doesn't resolve this bug, either.
> Has anyone tried to reproduce this in other browsers -- like Safari?

OK, let me ask this another way.  What other applications (besides Firefox and Camino) have built-in support for Growl notifications?  And if they exist, do they also have this problem?
Interestingly, the Growl home page (http://growl.info/) says the
following:

  For 10.6 Snow Leopard, do not install 1.1.6. We are working on Growl
  1.2 for 10.6 Snow Leopard

I'm going to put this bug aside until Growl 1.2 is available.
Chris, maybe you can answer my question from comment #7.

Comment 10

10 years ago
No other applications have this problem. We have over 200 applications with built-in support. Go to http://growl.info/applications.php to look at this. Most of these apps use the framework as we ship it.
I *really* need better steps to reproduce for this bug.

For example, what does "Tab Mix Plus - F9 key" mean?  I'd like a detailed, step-by-step description.  (And yes, I've already installed Tab Mix Plus and pressed the F9 key -- nothing happened.)
> I *really* need better steps to reproduce for this bug.

OK, I've now found them.  I also now realize that I completely
misunderstood this bug:  I thought it happens when Firefox *receives*
a Growl notification.  It actually happens when Firefox *sends* one.
(And in fact I'm not sure Firefox (or any other application) *can*
"receive" a Growl notification.)

1) Make sure Growl is installed and running, and that the following
   setting is 'true' (which it is by default):

   browser.download.manager.showAlertOnComplete

2) In a current Namoroka or Minefield nightly, start downloading a file.

   Minimize the Downloads window before the download finishes.  But
   make sure an ordinary browser window (e.g. the one containing the
   link from which you downloaded the file) remains open and focused.

3) Wait until the download finishes.  When it does finish the browser
   will display a Growl alert.

   If this is the first Growl alert displayed since you started the
   browser, the browser window will lose focus.
Summary: Window loses focus on Growl notification in 10.6 → [10.6] Window loses focus on Growl notification in 10.6
This should be fixed (on the trunk) by the patch for bug 522511.
Status: NEW → RESOLVED
Last Resolved: 10 years ago10 years ago
Resolution: --- → FIXED
The patch for bug 522511 has now been landed on the 1.9.2 branch.
status1.9.2: --- → final-fixed

Comment 15

10 years ago
(In reply to comment #14)
> The patch for bug 522511 has now been landed on the 1.9.2 branch.
sorry for maybe this stupid question. As I have this issue as well, when can we expect a release?
Target Milestone: --- → Firefox 3.7a1
Verified fixed on trunk and 1.9.2 with

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.3a1pre) Gecko/20091102 Minefield/3.7a1pre ID:20091102034445

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2b2pre) Gecko/20091101 Namoroka/3.6b2pre ID:20091101033813

The reported issue does not exist on 1.9.1. Marking as unaffected.
Status: RESOLVED → VERIFIED
status1.9.1: --- → unaffected
Keywords: verified1.9.2
Hardware: x86 → All
Version: unspecified → Trunk
You need to log in before you can comment on or make changes to this bug.