If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

ignoring margin-right and margin-bottom on absolutely positioned elements

VERIFIED FIXED in M5

Status

()

Core
Layout
P3
normal
VERIFIED FIXED
19 years ago
19 years ago

People

(Reporter: dbaron, Assigned: troy)

Tracking

Trunk
x86
Windows 95
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
You're ignoring non-auto margin-right and margin-bottom on absolutely
positioned elements.  I think you're setting them to zero somewhere where you
shouldn't be.  (You know, one of those things in CSS2 section 10.3.7 or 10.6.3.)

I think the test is right.  The above explanation explains all the problems in
the above URL.  It's worth checking though.  (And there could also be something
in the CSS2 rules that I'm missing.)
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M5
(Assignee)

Comment 1

19 years ago
It's kind of difficult exactly what's wrong, because it's such a complicated
test with many examples.

It would help considerably if you could either give me a reduced example, or
give me a specific example (e.g., class=four) of one case to look at and what's
wrong

Thanks,
Troy
(Reporter)

Comment 2

19 years ago
The problem is in classes two (right only), three (bottom only, since margin-
right is 0) and four (bottom only).  The P with class two is 2em too far to the
right.  The P with class three is 2em too low.  The P with class four is 1em
too low.  (The same problems occur in both halves.)
(Assignee)

Comment 3

19 years ago
Thanks. I'll take a look
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 4

19 years ago
Okay, it was hard to track down, but I found it. One of the code paths (the case
where one and only one of 'left/right' or 'top/bottom was 'auto') was forgetting
to take the non-auto value into account
(Reporter)

Updated

19 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 5

19 years ago
Verified fixed.
You need to log in before you can comment on or make changes to this bug.