Closed Bug 515432 Opened 10 years ago Closed 10 years ago

Jetpack crashes on Linux

Categories

(Mozilla Labs :: Jetpack Prototype, defect)

x86
Linux
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 518170

People

(Reporter: ddahl, Unassigned)

Details

Here is the output from just loading about:jetpack on linux:

Thanks for using Jetpack with Firebug! Please note that if you want to see your Jetpack's logging messages, you'll have to switch to the Firebug panel on the about:jetpack tab.
aMainWindow.getBrowserFromContentWindow is not a function
[Break on this error] return aMainWindow.getBrowserFromContentWindow(aWindow);\n
xulapp.js (line 71)
browser is null
[Break on this error] Filtered chrome url chrome://jetpack/content/js/log.js
log.js (line 227)
console is not defined
[Break on this error] Filtered chrome url chrome://jetpack/content/js/jetpack-environment.js
jetpack-...onment.js (line 125)
SecureMembrane is not defined
[Break on this error] Filtered chrome url chrome://jetpack/content/js/jetpack-runtime.js
jetpack-...untime.js (line 69)
aMainWindow.getBrowserFromContentWindow is not a function
anonymous()xulapp.js (line 71)
anonymous()init-extension.js (line 109)
(?)()init-extension.js (line 86)
[Break on this error] return aMainWindow.getBrowserFromContentWindow(aWindow);\n
xulapp.js (line 71)
browser is null
[Break on this error] Filtered chrome url chrome://jetpack/content/js/log.js
log.js (line 227)
Cc['@labs.mozilla.com/jetpackdi;1'] is undefined
[Break on this error] Filtered chrome url chrome://jetpack/content/js/secure-membrane.js
secure-m...mbrane.js (line 15)
On windows/Fx nightly, I get a "The URL is not valid and cannot be loaded." alert when I try to visit about:jetpack
I was able to run the test suite from the cmd line on windows, but 22 tests failed:


[message]: 76 out of 98 tests successful ( 22 failed ).
Tests failed: 22
Tests succeeded: 76
most of the errors were this: [ERROR]  : Cc['@labs.mozilla.com/jetpackdi;1'] is undefined
I'm seeing this on OS X too, with Namaroka.

Error: Cc['@labs.mozilla.com/jetpackdi;1'] is undefined
Source File: chrome://jetpack/content/js/secure-membrane.js
Line: 15
It turns out that the binary component is only compatible with Firefox 3.5.x, anything on trunk or branch is not gonna work. Runt he test suite on the command line with -b /path/to/fx3.5.x
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 518170
You need to log in before you can comment on or make changes to this bug.