Lightning plugin cannot be installed on Thunderbird/3.0b3

VERIFIED INVALID

Status

Calendar
General
--
major
VERIFIED INVALID
8 years ago
8 years ago

People

(Reporter: Shree, Unassigned)

Tracking

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2 AutoPager/0.5.2.2 (http://www.teesoft.info/)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.1) Gecko/20090715 Thunderbird/3.0b3

Tried to install lightning plugin on Thunderbird/3.0b3 but got the following error:

Lightning 1.0pre could not be installed because it is not compatible
with Thunderbird 3.0b3

I tried to install the following versions of lightning:
+ lightning-0.9-tb-linux.xpi
+ lightning-1.0pre

Thunderbird version:
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.1) Gecko/20090715 Thunderbird/3.0b3



Reproducible: Always

Steps to Reproduce:
1. Download the plugin
2. Install via the Tools/Add-ons menu
3. Get the error when I click install1.

Actual Results:  
Getting the following error:

Lightning 1.0pre could not be installed because it is not compatible
with Thunderbird 3.0b3


Expected Results:  
Should install lightning as a plugin
Due to API changes in Thunderbird in its beta 4 pre cycle (see bug 500506), Lightning was updated to meet those changes, as a result Lightning is no longer backwards compatible with Thunderbird 3.0b3.

Thunderbird 3.0b4 should be out within the next couple of weeks.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID

Updated

8 years ago
Status: RESOLVED → VERIFIED

Comment 2

8 years ago
The latest test build that is compatible with Thunderbird 3.0b3 is the 2009-09-08 nightly build. You can download it from http://ftp.mozilla.org/pub/mozilla.org/calendar/lightning/nightly/2009/09/2009-09-08-03-comm-1.9.1/linux-xpi/
You need to log in before you can comment on or make changes to this bug.