If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

when installing an addon, tabs should be restored on restart

VERIFIED FIXED

Status

Fennec Graveyard
General
VERIFIED FIXED
8 years ago
7 years ago

People

(Reporter: Pike, Assigned: mfinkle)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
I installed an addon on my n810 today, and restarted the browser.

I expected to get my tabs back like on fx, but didn't.
OS: Linux → All
Hardware: ARM → All
Depends on: 541421
Created attachment 500455 [details] [diff] [review]
patch

Now that we have SessionRestore and restore-on-crash, this was easy to implement. I borrowed the same pref used by desktop Firefox. Our impl is just much simpler than desktop.

Tested and it works nicely.
Assignee: nobody → mark.finkle
Attachment #500455 - Flags: review?(mbrubeck)
Duplicate of this bug: 622219
Attachment #500455 - Flags: review?(mbrubeck) → review+
pushed:
http://hg.mozilla.org/mobile-browser/rev/ac89d1f54389
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED

Comment 4

7 years ago
verified fixed on build id: Mozilla /5.0 (Android;Linux armv7l;rv:2.0b13pre)
Gecko/20110304 Firefox/4.0b13pre Fennec /4.0b6pre
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.