Cannot change add-on version license in dev tools

VERIFIED FIXED in 5.1

Status

defect
--
major
VERIFIED FIXED
10 years ago
3 years ago

People

(Reporter: fcp2007, Assigned: clouserw)

Tracking

({regression})

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
I have been using a custom license for all versions of my add-on.  However, I cannot select the same custom license for the new version which I uploaded today.

Steps to Reproduce:
Because I do not know the criteria which trigger this bug, I just write down what I did.
1. Log in as me.  :)
2. Visit the developer page for Link Status 1.3 at https://addons.mozilla.org/en-US/developers/versions/edit/78186
3. Observe that none of the license options is selected.
4. Select “Custom license for add-on 12312 v0.0” and click Update Version.
5. Wait for a few hours (to make sure that it is not a problem with caching on the server side).
6. Visit https://addons.mozilla.org/en-US/firefox/addons/versions/12312#version-1.3, reload, and see if the license is shown for version 1.3.

Actual Results:
In Step 6, no license is shown.

Expected Results:
In Step 6, “Source Code License [Custom License]” is shown.

Additional Information:
It is strange in the first place that in Step 3, none of the license options is selected.  When I uploaded the previous version, the custom license was selected by default.

Comment 1

10 years ago
I'm getting this with Flagfox 3.3.16 too. It won't let me select my license for the latest update. If I select it and save I get the "Your changes have been saved." message, but the radio list of licenses has nothing selected and nothing will show on the all versions page. The file is currently still listed as "In Sandbox; Pending Review" after 9 days and the previous version (3.3.15) is still shown for "Latest Version" on the main dashboard page, which is leading me to think that the submission is somehow incomplete, possibly in some part because of this.
Severity: normal → major
Keywords: regression
(Reporter)

Comment 2

10 years ago
(In reply to comment #1)
> I'm getting this with Flagfox 3.3.16 too. It won't let me select my license for
> the latest update. If I select it and save I get the "Your changes have been
> saved." message, but the radio list of licenses has nothing selected and
> nothing will show on the all versions page.

Same here.

> The file is currently still listed
> as "In Sandbox; Pending Review" after 9 days and the previous version (3.3.15)
> is still shown for "Latest Version" on the main dashboard page, which is
> leading me to think that the submission is somehow incomplete, possibly in some
> part because of this.

I am not sure if this part is really related to this bug.  Although I agree that it would be better if editor reviews were faster, currently 9 days does not sound like an exceptionally long delay to me.

Comment 3

10 years ago
(In reply to comment #2)
> (In reply to comment #1)
> > The file is currently still listed
> > as "In Sandbox; Pending Review" after 9 days and the previous version (3.3.15)
> > is still shown for "Latest Version" on the main dashboard page, which is
> > leading me to think that the submission is somehow incomplete, possibly in some
> > part because of this.
> 
> I am not sure if this part is really related to this bug.

What I mean is that the "current version" should be showing as 3.3.16 (the sandboxed version) not 3.3.15. Wasn't this showing the latest version regardless of status before, or am I misremembering?

> Although I agree
> that it would be better if editor reviews were faster, currently 9 days does
> not sound like an exceptionally long delay to me.

This was a routine monthly IP location database update with no code or locale changes. Same JAR; just the new db.dat and some install.rdf bumps. I usually get a review in a day or so as there's not much to review.
(Reporter)

Comment 4

10 years ago
(In reply to comment #3)
> What I mean is that the "current version" should be showing as 3.3.16 (the
> sandboxed version) not 3.3.15. Wasn't this showing the latest version
> regardless of status before, or am I misremembering?

Oh, then I do not know the correct behavior.  In my case, after the public nomination of version 1.1 was approved, I updated the add-on just twice (1.2 and 1.3).  All the time, the developer dashboard has been showing “Latest Version: 1.1 (1 Public file)”.

By the way, version 1.2 of my add-on was not reviewed by an editor before I uploaded 1.3 (27 days after I uploaded 1.2).  I understood it as an evidence that editors were probably heavily backlogged, but I might have been wrong.

> > Although I agree
> > that it would be better if editor reviews were faster, currently 9 days does
> > not sound like an exceptionally long delay to me.
> 
> This was a routine monthly IP location database update with no code or locale
> changes. Same JAR; just the new db.dat and some install.rdf bumps. I usually
> get a review in a day or so as there's not much to review.

Now I understand why you think that 9 days is strange.  Thanks for clarifying it.

Comment 5

10 years ago
(In reply to comment #4)
> that editors were probably heavily backlogged, but I might have been wrong.

Was what I was thinking too. I didn't even think about it still not being approved until I read this bug and realized my license still wasn't showing. I vaguely remember someone saying they were particularly overloaded at some point, but I forget exactly when that was.

> Now I understand why you think that 9 days is strange.  Thanks for clarifying

A somewhat longer wait for me is not that big of a deal so long as it gets out before it's already almost time for the next one. ;) I was only quoting the delay because the license is part of the submission process and thus the submission isn't fully going through. It of course could just as easily have nothing to do with anything here.
(Reporter)

Comment 6

10 years ago
Just in case, I filed bug 515948 about the “Latest Version” not being updated in the developer dashboard.  The cause of 515948 might be the same as the cause of this bug.  It can be marked as a duplicate once it turns out to be the case.
(Reporter)

Comment 7

10 years ago
According to Archaeopteryx on the #addons channel of IRC (thanks!), FlagFox is shown as pending review for 9 days, and Link Status 1.3 is also shown as pending review for a day.  Judging from this, reviews of FlagFox 3.3.16 and Link Status 1.2 were probably taking time just because editors are busy, not because of a bug of AMO.
(Assignee)

Updated

10 years ago
Target Milestone: --- → 5.1
I'm changing the summary since it doesn't seem to work for non-custom licenses either (now is 'Cannot change add-on version license in dev tools'). I've just experienced the same problem with the most recent update to Fire.fm. I can't set it's license (BDS) in any way, even though the site says my changes were saved.
Summary: Cannot change add-on license to an existing custom license → Cannot change add-on version license in dev tools
(Assignee)

Comment 9

10 years ago
Posted patch fixSplinter Review
This appears to have been broken since Aug 20th. :(!
Assignee: nobody → clouserw
Attachment #401446 - Flags: review?(smccammon)
Attachment #401446 - Flags: review?(smccammon) → review+
Comment on attachment 401446 [details] [diff] [review]
fix

The patch works as advertised. R+
(Assignee)

Comment 11

10 years ago
r51851
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED

Comment 12

10 years ago
Thanks Wil! I don't suppose some automated tests could be written for this?
Verified FIXED (at first I didn't think it was working, but it takes just a couple minutes--literally--for the changes to show up).

Dave/fcp, if you guys could also confirm on preview, that would be great.
Status: RESOLVED → VERIFIED

Comment 14

10 years ago
Everything is working perfectly now, thanks.
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.