Merge CtrlTabs and AllTabs into one feature

RESOLVED WONTFIX

Status

()

Firefox
General
--
enhancement
RESOLVED WONTFIX
8 years ago
5 years ago

People

(Reporter: [not reading bugmail], Unassigned)

Tracking

Trunk
x86
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.3a1pre) Gecko/20090910 Minefield/3.7a1pre (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.3a1pre) Gecko/20090910 Minefield/3.7a1pre (.NET CLR 3.5.30729)

Since CtrlTabs and AllTabs are very similar, and CtrlTabs is much further along and cleaner.  We should think about creating a single combined feature.  Add search to CtrlTabs and ability to display as a panel matrix like AllTabs and it would be done, I like CtrlTabs ability to switch between tabs, but AllTabs doesn't have such functionality.



Reproducible: Always




If this was a single feature but had _parameters to control its output, that would be better than implementing two completely different implementations of very similar features.

See other browsers for design ideas for single preview/UI behavior.  Also very similar functionality is being tossed around as new UI for about:blank.
do you have the new ctrl+tab panel enabled?
Version: unspecified → Trunk
(Reporter)

Comment 2

8 years ago
Yeah.  I checked out both, I could open the All-tabs from the Ctrl-Tabs.. but I was thinking is there an alternative option here.

Updated

6 years ago
Depends on: 670684
"All Tabs" panel code removed in bug 670684.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.