[faceted search]: should be able to refine a search with more words

RESOLVED DUPLICATE of bug 519006

Status

Thunderbird
Search
RESOLVED DUPLICATE of bug 519006
9 years ago
9 years ago

People

(Reporter: davida, Assigned: davida)

Tracking

Trunk
Thunderbird 3.0rc1
Bug Flags:
blocking-thunderbird3 -

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [maybe has l10n impact])

(Assignee)

Description

9 years ago
i suspect standard8 can give us pointers at least.
Flags: blocking-thunderbird3?
Flags: blocking-thunderbird3? → blocking-thunderbird3+
Target Milestone: --- → Thunderbird 3.0rc1
Component: Mail Window Front End → Search
QA Contact: front-end → search

Updated

9 years ago
Whiteboard: [no l10n impact]
(Assignee)

Comment 1

9 years ago
Turns out this is hard, because all of the text one might want to look for is actually inside the anonymous nodes in the XBL bindings.  The right thing is likely to morph this bug into a feature where one can refine the full-text search from any faceted search.  I have an idea that I'll mockup/prototype.  If it's too hard, it may end up not-blocking.
Assignee: nobody → david.ascher
Status: NEW → ASSIGNED
(Assignee)

Updated

9 years ago
Whiteboard: [no l10n impact] → [maybe has l10n impact]
(Assignee)

Comment 2

9 years ago
Morphing this bug to deal with the root desire, not the initial implementation thoughts.  The use case is "search for a word, get too many results, want to search for a smaller set".

Open question: whether to keep the existing faceting restrictions, or reset them.  My inclination is to reset them, because the existing faceting is likely not that useful if the search was not successful.  Also, it's much easier to do in the time available for rc1.
Summary: [faceted search]: ctrl+f to do find-as-you-type should work → [faceted search]: should be able to refine a search with more words
(Assignee)

Comment 3

9 years ago
Talking to bryan, getting this right is going to be too hard.  The status quo isn't that bad (just type more words in the search field).
Flags: blocking-thunderbird3+ → blocking-thunderbird3-
(Assignee)

Comment 4

9 years ago
Bug 519006 will handle this.
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 519006
You need to log in before you can comment on or make changes to this bug.