Closed Bug 515893 Opened 10 years ago Closed 10 years ago

Thunderbird OSX dock icon shows wrong unread mail count

Categories

(Thunderbird :: OS Integration, defect)

x86
macOS
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 274688

People

(Reporter: rlange, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3
Build Identifier: version 2.0.0.23 (20090812)

The OSX dock icon for Thunderbird displays an unread mail count as a little green badge over the standard Thunderbird icon.  However, this count is the number of new messages since the last mail check, not the total number of unread messages in the inbox.

Reproducible: Always

Steps to Reproduce:
1. Send a mail to your account.
2. Open Thunderbird.  Alternatively, if Thunderbird is already open, click the "Get Mail" button.  Notice the unread mail count in on the dock icon.
3. Without actually reading the new mail, immediately click the "Get Mail" button again.
Actual Results:  
Notice that although the unread mail remains in the inbox, the unread mail count on the dock icon disappears (unless of course you just got more new mail).

Expected Results:  
The OSX dock icon for Thunderbird should show the total count of unread mail in the inbox.
I'm pretty sure we already have a bug on the subject.
Whiteboard: dupme
Fixed it too on trunk.
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 274688
Cleanup *dupeme* whiteboard flag from bugs that are marked as Resolved
Duplicate!
Whiteboard: dupme
You need to log in before you can comment on or make changes to this bug.