text mail content is not displayed in some mails from outlook

RESOLVED INCOMPLETE

Status

RESOLVED INCOMPLETE
9 years ago
8 years ago

People

(Reporter: dieter.ferdinand, Unassigned)

Tracking

x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [closeme 2011-02-01])

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.0.14) Gecko/2009082707 Firefox/3.0.14 (.NET CLR 3.5.30729)
Build Identifier: Version 2.0.0.21 (20090302)

hallo,
i have problem with some mail from outlook.

this mails are displayed without content.

if i change from orig-html to text only or simple html, i get the text from the mail.
i also get the the text in the print preview!

after this, i get the text if i reopen the mail, the text is already displayed.

i think, this is a problem with the character encoding. i has the same problem some times ago because i set a default encoding for the mail, so the mails from outlook, which have an other encoding, no text ist displayed.
i changed the setting, to use the encoding of the mail and it works, but this the setting for this client.

the program must display all text in the mails with the encoding charset of the mail or the default charset and not display an empty mail, if there is something wrong!
if there is no content displayed and the mail have a text content, this is not good.

i have copied some lines of the mail:
This is a multi-part message in MIME format.

------=_NextPart_000_00A9_01CA32F6.BBF1A580
Content-Type: multipart/related;
	boundary="----=_NextPart_001_00AA_01CA32F6.BBF1A580"


------=_NextPart_001_00AA_01CA32F6.BBF1A580
Content-Type: multipart/alternative;
	boundary="----=_NextPart_002_00AB_01CA32F6.BBF1A580"


------=_NextPart_002_00AB_01CA32F6.BBF1A580
Content-Type: text/plain;
	charset="iso-8859-1"
Content-Transfer-Encoding: quoted-printable


Reproducible: Sometimes




this problem is at this time only known with mail from outlook
This looks like a nested multi-mime issue. could you find a email that show the error and that you could share with us ? save it as a .eml file (using File->save) and attach it to this bug ?
Version: unspecified → 2.0
Dieter, please, could you answer to comment #1?
Whiteboard: [closeme 2011-02-01]
RESOLVED INCOMPLETE due to lack of response to previous question. If you feel this change was made in error, please comment in this bug with your reasons why.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.