Severe Memory Leakage with new release of 3.5.3

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
9 years ago
8 years ago

People

(Reporter: u212676, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [closeme 2010-10-25])

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3 (.NET CLR 3.5.30729)

Since loading the latest version of Firefox (3.5.3), my PC's RAM (max 512 mb)is often exceeded, even when Firefox is sitting idling doing nothing with one tab open.

When it closes, it takes forever to shutdown in Task Manager.

Reproducible: Always

Steps to Reproduce:
1. open browser
2. view home page
3. close browser
Actual Results:  
Closes on the desktop, but remains active in Task Manager for several minutes...

Comment 1

9 years ago
This might be caused by one of your extensions ? Do you see it in Safe Mode ?

http://support.mozilla.com/en-US/kb/Safe+Mode

Comment 2

9 years ago
Mozilla/5.0 (OS/2; U; Warp 4.5; nl-NL; rv:1.9.1.3) Gecko/20090906 Firefox/3.5.3

Even in safemode memory usage is only adding and not giving back to the system. I tested it with my homepage which uses frames. Only changing content frame with no javascript in it with three pages in a loop will add up memory usage with about 6mb pro page. After a while this stops, probably because the cache has enough. But going to the main page and doing nothing does not free memory. Also going to a total different page, ie going out of the structure of my homepage, will not free the used memory. The new pages, ie this page as an example, will add up to the memory usage. This page alone will take approx. 40mb, but I'm unaware what is all loaded just to give this message. Used together with other programs can crash the system due to (shared) memory problems. Unfortunately there is no add-on which shows what is using the memory, ie what is using within FF.

Comment 3

9 years ago
Mozilla/5.0 (OS/2; U; Warp 4.5; nl-NL; rv:1.9.1.3) Gecko/20090906 Firefox/3.5.3

Going back to my homepage after my message, see 2009-09-29 20:47:29 PDT, will not free the taken approx. 40mb, memory used by the new site will add up and this stays until the program is shutdown and restarted.

Comment 4

8 years ago
do you still see this with version 3.6?
Whiteboard: [closeme 2010-10-25]

Comment 5

8 years ago
I use now Mozilla/5.0 (OS/2; U; Warp 4.5; nl-NL; rv:1.9.2.8) Gecko/20100724 Firefox/3.6.8 and I think that the answer is yes. I didn't do the above test but when I load for instance google the system hangs on something, processor load rising way up to 99,99%. Can't do a thing during that time, when I'm too nervous FF crashes hard. There is no activity on drives, nor memory. Puzzled. Having a big picture on the screen, do more with photo today, and want to start EXIF view, system crashes sometimes. Why unknown. Also bookmarks aren't read correct. With blanc system, first bookmark okay, second start bookmark doesn't start on mouse click, but the thing under the bookmark of the previous page start. Second time it does do it. Copy an address don't go, with pasting that address al kinds of character are missing, for instance the "t" in "hp://" instead of "http://". I can do this over and over again with same results.

Comment 6

8 years ago
joop, your issue sounds like something different than reporter's. 

Perhaps in part bookmarks related. And, do you see it in safe mode? http://support.mozilla.com/en-US/kb/Safe+Mode
No reply, INCOMPLETE. Please retest with Firefox 3.6.11 or later and a new profile (http://support.mozilla.com/kb/Managing+profiles). If you continue to see this issue with the newest firefox and a new profile, then please comment on this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 8

8 years ago
Memory leakage issue seems to have been addressed in Firefox 3.6.11
Resolution: INCOMPLETE → FIXED

Updated

8 years ago
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.