unstable if many flash movies is loading

RESOLVED WORKSFORME

Status

()

Core
Plug-ins
RESOLVED WORKSFORME
9 years ago
8 years ago

People

(Reporter: Filip Zakrzewski, Unassigned)

Tracking

1.9.1 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [closeme 05-05-2010])

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; pl; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; pl; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3 (.NET CLR 3.5.30729)

When I'm trying to load many flash movies (~30min - 3-7) at the same time Firefox is unstable. I can't use expanding menu (expand File, Edit, etc. or expand Adblock Plus options in a status bar) - that menu is invisible (visible is only menu outline)

Reproducible: Sometimes

Steps to Reproduce:
1. Begin to load 3 to 7 flash movies
2. Wait few minutes (but don't let movies 100% loaded)
3. Try to expand File, Edit or whatever
Actual Results:  
You can't use expanding menu (expand File, Edit, etc. or expand Adblock Plus options in a status bar) - that menu is invisible (visible is only menu outline)

Expected Results:  
Expand visible and working menu

I'm using default theme

My computer configuration is :
AMD 3.11 GHz (64bit, 2 core)
4GB RAM
Windows 7 Ultimate (and Windows XP)
Geforce 9600GT 512MB
HDD 1TB


about:buildconfig

Source

Built from http://hg.mozilla.org/releases/mozilla-1.9.1/rev/0da982f65d37
Build platform
target
i686-pc-mingw32

Build tools
Compiler 	Version 	Compiler flags
cl 	14.00.50727.762 	-TC -nologo -W3 -Gy -Fdgenerated.pdb -DNDEBUG -DTRIMMED -Zi -UDEBUG -DNDEBUG -GL -wd4624 -wd4952 -O1
cl 	14.00.50727.762 	-GR- -TP -nologo -Zc:wchar_t- -W3 -Gy -Fdgenerated.pdb -DNDEBUG -DTRIMMED -Zi -UDEBUG -DNDEBUG -GL -wd4624 -wd4952 -O1

Configure arguments
--enable-application=browser --enable-update-channel=release --enable-update-packaging --enable-jemalloc --enable-official-branding --with-crashreporter-enable-percent=10
Just to be sure that this isn't a bug in an add-on, can you retest in safe-mode?
And do you mean 7 different sites or one site with 7 movies. In that case can you give a link?
Version: unspecified → 3.5 Branch
(Reporter)

Comment 3

9 years ago
First time i've met that error when I was using "clean" Firefox (without any add-on)

example site with few movies (open in new tab) :
http://vids.myspace.com/index.cfm?fuseaction=vids.channel&vanity=461286825
(but the same bug I've met on sevenload.com so I think it's not player error)
If open 6 of those movies on that page in new tabs the menus are indeed slower. 
Internet Explorer has even more problems with 6 tabs; it gets unresponsive.
So I think this is a performance problem.
(Reporter)

Comment 5

9 years ago
Sorry, i'm only using Firefox and Chrome 3 (occasionaly) so I don't know how about IE.
There is no way to repair it at the moment?
I see no problem if they are loaded in the background. Do you want to hear them all together?
(Reporter)

Comment 7

9 years ago
No, but I know peoples (sometimes i'm doing it too) who are buffering few movies at the same time (because of slow internet connection)

Example :
I've loaded 1 movie in ~80-90%, then i'm opening new tab with another movie and beginning loading it, then third, and fourth. Sometimes up to 7-9
Component: General → Plug-ins
Product: Firefox → Core
QA Contact: general → plugins
Version: 3.5 Branch → 1.9.1 Branch
What is your cpu load when having more then 5 tabs open with Flash movies?
(Reporter)

Comment 9

9 years ago
~50% when I've just opened tabs with flash movies
~50-55% (very rare up to 66%) while I'm loading movies

Comment 10

8 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.3a4) Gecko/20100407 MozillaDeveloperPreview/3.7a4                                                   Please update if you are able to still reproduce with the latest trunk build  http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/3.6.4-candidates/
Whiteboard: [closeme 05-05-2010]
(Reporter)

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
No patch -> WFM
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.