Firefox freezes when calling javascript:window.open() with width and height given.

RESOLVED FIXED

Status

()

P2
major
RESOLVED FIXED
9 years ago
8 years ago

People

(Reporter: daniel.rconcept, Unassigned)

Tracking

3.5 Branch
x86
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; fr; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; fr; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3 (.NET CLR 3.5.30729)

Firefox freezes when calling window.open() in a javascript with the windowFeatures containing "width=nnn" and/or "height=nnn" (nnn being a valid number between 100 and 800).
It happend every time, with firefox 3.5.2 and 3.5.3, on "Windows Vista Ultimate x64"
and "Windows XP pro"


Reproducible: Always

Steps to Reproduce:
1. create a page like this, and save it as "test.html"
 <html>
 <head>
 <script language="javascript">
 function myopenwin(){
	hdWindow = window.open(mlink, 'WinName1', "width=750, height=400" );
 }
 </script>
 </head>
 <body>
 <form name="f1" action="test.html" method="get">
 <a HREF="javascript:myopenwin()">test on &lt;A&gt; [working]</a><br>
 test with onchange()  [not working]:
 <select size="1" name="var1" onChange="myopenwin()">
	<option value="">Empty
	<option value="1">1
 </select>
 <br> test with onclick() [not working]: <input name="b1" type="button" value="go" onclick="myopenwin()">
 </form>
 </body>
 </html>

2. load this page "test.html" into firefox
3. click on the first link works, the other to don't.
Actual Results:  
freezes firefox

Expected Results:  
opne a new window with the same content
(Reporter)

Updated

9 years ago
Priority: -- → P2
Version: unspecified → 3.5 Branch
(Reporter)

Comment 1

9 years ago
Sorry for the sloppy report. Here is the correct one:

1. Create a page like the this, and save it as "test.html". Upload it to a server because when you load it in firefox, it has to be via 'http://' not 'file://'. The bug only shows up in the 'http://' mode.
 
 <html>
 <head>
 <script language="javascript">
 function myopenwin(){
    hdWindow = window.open("test.html", 'WinName1', "width=750, height=400" );
 }
 </script>
 </head>
 <body>
 <form name="f1" action="test.html" method="get">
 <a HREF="javascript:myopenwin()">test on &lt;A&gt; [working]</a><br>
 test with onchange()  [not working]:
 <select size="1" name="var1" onChange="myopenwin()">
    <option value="">Empty
    <option value="1">1
 </select>
 <br> test with onclick() [not working]: <input name="b1" type="button"
value="go" onclick="myopenwin()">
 </form>
 </body>
 </html>

2. Load this page "test.html" into firefox
3. Clicks on the first link work, the other two don't.

Actual Results:  
 Freezes firefox

Expected Results:  
 Open a new window with the same content

Comment 2

8 years ago
I'm afraid your bug is not reproductible for me.
The tree links are opening the right page, no freezing.

The issue might have been fixed between your version and 3.6.6. You should update your firefox.


Windows XP SP3
Firefox 3.6.6
(Reporter)

Comment 3

8 years ago
Yep, I retested it with Firefox 3.6.6 on windows XP SP3 and windows 7. 
I was unable to reproduce the bug.
Both system give the correct result on all actions.
Thanks anyway for your time to check it out after so much time.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.