Special characters shown as '?' in title bar

RESOLVED DUPLICATE of bug 373398

Status

()

Firefox
General
--
trivial
RESOLVED DUPLICATE of bug 373398
9 years ago
9 years ago

People

(Reporter: Kelly Johnson, Unassigned)

Tracking

3.5 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2 (.NET CLR 3.5.30729) AutoPager/0.5.2.2 (http://www.teesoft.info/)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2 (.NET CLR 3.5.30729) AutoPager/0.5.2.2 (http://www.teesoft.info/)

Navigate to a site that has a special character in the page title, such as ở in the given wikipedia URL

Reproducible: Always

Steps to Reproduce:
1. Go to the given website
2. Look at the title
3. see a ? where a ở should be
Actual Results:  
? is displayed for ở

Expected Results:  
ở is displayed for ở
I guess Windows doesn't have the characters for the font-type in this language. You can test that by changing the font Windows is using for the titlebar. If Windows is using Tahoma, try Verdana or such.
Whiteboard: [DUPEME]
Version: unspecified → 3.5 Branch

Comment 2

9 years ago
Your titlebar is handled by your OS. If it can't render the character then you don't have the font for it for some reason or the font you're using doesn't have the characters you need. Windows doesn't have a lot of the fonts it needs installed by default, so you may have to install them for some languages. You'll get the same problem with other applications.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Whiteboard: [DUPEME]
Duplicate of bug: 373398
You need to log in before you can comment on or make changes to this bug.