detect-flash.js should not warn users for Flash Player 9.0.246.0 (latest secure Flash v9)

RESOLVED WONTFIX

Status

P1
normal
RESOLVED WONTFIX
9 years ago
5 years ago

People

(Reporter: beltzner, Assigned: morgamic)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

Need to update the script to not warn if users have Flash Player version 9.0.246.0 which is apparently the latest secure version.

Comment 1

9 years ago
maybe we can still warn them about stability gains of moving to the latest version but not make the security claim?
(Assignee)

Comment 2

9 years ago
That's not true - there are 10.x versions that are vulnerable, no?
9.x and 10.x are separate branches.
From http://www.adobe.com/support/security/bulletins/apsb09-10.html --

Adobe recommends users of Adobe Flash Player 9.x and 10.x and earlier versions update to Adobe Flash Player 9.0.246.0 and 10.0.32.18.  Adobe recommends users of Adobe AIR version 1.5.1 and earlier versions update to Adobe AIR 1.5.2. Adobe recommends users of Adobe Reader 9 and Acrobat 9 and earlier versions update to Adobe Reader 9.1.3 and Acrobat 9.1.3.
Duplicate of this bug: 519236
Created attachment 405529 [details]
Flash  10.0.r32 on Mac 0S X (version 10.4.11 ) Dual 1.8 GHz PPC G5 

I was able to upgrade the flash version from 9 to 10.0.r32 on a PPC powered
Mac.
The fact that Flash 10 might be available for PPC doesn't change anything (but probably the subject of the bug).
Is this going to be fixed at some point?

If not, we are forced to change the homepage_override and _welcome urls in the default configuration to not confuse the users.
Summary: detect-flash.js should not warn users for Flash Player 9.0.246.0 (latest PPC version) → detect-flash.js should not warn users for Flash Player 9.0.246.0 (latest secure Flash v9)

Comment 8

8 years ago
This is affecting us on Ubuntu Hardy since we have the latest secure 9.x in the archive which is now 9.0.277, would it be possible to have the flash versions check to see if the first 2 numbers match a supported version (i.e. 9.0 and 10.1, not 10.0) and then check the last number?
Is 9.x still getting patched?
Component: www.mozilla.org/firefox → www.mozilla.org
Product: Websites → Websites
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
9.x is no longer supported.
http://www.adobe.com/support/flashplayer/downloads.html
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Component: General → Pages & Content
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.