Panels don't load content from foreign servers

VERIFIED WORKSFORME

Status

P4
major
VERIFIED WORKSFORME
18 years ago
14 years ago

People

(Reporter: BenB, Assigned: matt)

Tracking

({helpwanted, qawanted})

Trunk
Future
helpwanted, qawanted

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [NEED INFO][nsbeta3-][cut 0921])

(Reporter)

Description

18 years ago
Reproduce:
1. Create a panel with <img src="http://servera/img.png">
2. Upload the panel to serverb (i.e. a server different from the one holding the
img)
3. Add the panel to your sidebar, look at it.

Actual result:
Image doesn't appear

Expected result:
Image does appear

Additional comments:
It is stated that panels are just "small webpages". For webpages, it is common
to embed objects from other servers. If rejecting them in the sidebar is a
security feature, what is the rationale?
(Reporter)

Updated

18 years ago
Severity: normal → major
Keywords: nsbeta3
(Reporter)

Updated

18 years ago
Summary: Pnaels don't load content from other foreign servers → Panels don't load content from foreign servers

Comment 1

18 years ago
nav triage team:
QA, please verify - it surprises us that this would be the case
Whiteboard: [NEED INFO]

Comment 2

18 years ago
This is not the case for me. I just tried adding panels with png, jpg, gif's 
(located on servers different than the panel's ) and it works fine. Marking this 
WFM.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 3

18 years ago
I am behind a proxy, maybe this is the reason Can you test this with a png file
outside a normal (required, Squid) proxy, please? REOPENing.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Comment 4

18 years ago
let me see if i can reproduce the test environment.
(Reporter)

Comment 5

18 years ago
thanks. (BTW: it doesn't have to be a png - any img will do)

Comment 6

18 years ago
nav triage team:
marking works for me again (Don made me do it)
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 7

18 years ago
Please do not mark WORKSFORME unless you tested this. Having no time to test it
is no reason to close a bug. REOPENing and adding qawanted.
Status: RESOLVED → REOPENED
Keywords: qawanted
Resolution: WORKSFORME → ---

Comment 8

18 years ago
Taking ownership of this bug for investigation.
Assignee: slamm → don
Status: REOPENED → NEW

Comment 9

18 years ago
Nav triage team: We're minusing this for now, because we can't judge how big a 
problem this is until we have some data. Once we have data and see this 
reproduced, we'll re-evaluate.
Whiteboard: [NEED INFO] → [NEED INFO][nsbeta3-][cut 0921]
Since Don has left, Vishy is taking his bugs in bulk, pending reassignment.
thanks,
	Vishy
Assignee: don → vishy
(Assignee)

Updated

18 years ago
Keywords: nsbeta1

Updated

18 years ago
Whiteboard: [NEED INFO][nsbeta3-][cut 0921] → [NEED INFO][nsbeta3-][cut 0921][nsbeta1+]

Comment 11

18 years ago
nav triage team:

Marking nsbeta1+

Comment 12

18 years ago
nav triage team:

Resetting priority so that this bug gets retriaged
Priority: P3 → --

Comment 13

18 years ago
spam : changing qa to sujay (New Sidebar QA)
QA Contact: shrir → sujay

Comment 14

18 years ago
removing nsbeta1+ from status whiteboard, need to retriage this
Whiteboard: [NEED INFO][nsbeta3-][cut 0921][nsbeta1+] → [NEED INFO][nsbeta3-][cut 0921]

Comment 15

18 years ago
Reassigning to matt, marking nsbeta1+, p4, mozilla0.9.1. Not sure we REALLY,
REALLY need to fix this, but we should find out why it's not working.
Assignee: vishy → matt
Keywords: nsbeta1 → nsbeta1+
Priority: -- → P4
Target Milestone: --- → mozilla0.9.1
as discussed in nav team meeting, moving P4 and P5 nsbeta1+ bugs to Future. 
Keywords: helpwanted
Target Milestone: mozilla0.9.1 → Future

Comment 17

17 years ago
I've tested this using http://www.dork.com/mkt/blah.html as my sidebar web page.
It uses an image from http://www.e-z.net/~silverst/ for a sample and there is no
problem on .95. Someone else please check and make sure that I've tested this
correctly, (I've left blah.html on dork.com) -- it only takes a second. There's
even a link to add it to your sidebar.

Comment 18

17 years ago
Tested using Jon Califf's test page.  Works fine on my system.  Win2000, build
2001111603.

Comment 19

17 years ago
If this has now been tested as WFM, shouldn't it be tagged as such?
(It is currently the only bug for the Sidebar component marked as qawanted - cf
Bugathon page).
(Reporter)

Comment 20

17 years ago
Nobody else could reproduce it (although nobody tested it using a proxy, it
seems), so I'll mark WFM myself. If I see the bug again (and preferably have
better repro info), I can reopen.
Status: NEW → RESOLVED
Last Resolved: 18 years ago17 years ago
Resolution: --- → WORKSFORME

Comment 21

17 years ago
verified.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.