Closed Bug 516290 Opened 12 years ago Closed 2 years ago

tabs flicker

Categories

(Core :: ImageLib, defect)

2.0 Branch
x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: Peter6, Unassigned)

References

Details

(Keywords: regression, Whiteboard: [decodeondraw])

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.3a1pre) Gecko/20090913 Minefield/3.7a1pre ID:20090913050738

repro:
I have no good str
open FF with multiple tabs

result:
wait and notice the tabs flicker from time to time

I don't know if bug 512435 or bug 435296 is to blame
Blocks: 435296
Component: General → ImageLib
QA Contact: general → imagelib
Going back to a background tab will "flicker" as images redecode. Assuming you're talking about the foreground tab, this will be fixed by bug 512260.

Let me know if I'm missing anything.
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 512260
I believe Peter was talking about the tab strip itself. If you wait 15 seconds for the images to be discarded and then mouse over the tab strip all the icons will flicker.

Also all the icons in my bookmark sidebar disappear if I close it and then reopen it after a while, and the icons for bookmarks on the bookmark toolbar will flicker when opening/closing the bookmark sidebar.

Those may all be related to bug 512260 though.
Reopening. This is indeed the behavior described in bug 512260, but I want to make sure we don't forget to handle favicons, since I'm not sure they're descendant frames of the presshell.

This bug will almost certainly disappear with bug 511899 (since we don't really gain anything by discarding favicons), but I don't want this to depend on a side effect of our discarding heuristic. We should probably just lock all favicons for good.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Whiteboard: [decodeondraw]
Version: unspecified → 2.0 Branch
Status: REOPENED → RESOLVED
Closed: 12 years ago2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.