Up arrow in URL bar clears the URL field

VERIFIED FIXED in mozilla0.9.1

Status

SeaMonkey
Location Bar
P5
normal
VERIFIED FIXED
18 years ago
10 years ago

People

(Reporter: Simon Fraser, Assigned: Joe Hewitt (gone))

Tracking

Trunk
mozilla0.9.1

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: Fix in hand)

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
In a new browser window, which has loaded a page by default (e.g. mozilla.org), 
pressing the up arrow clears the url bar. It should not.

It appears that the url bar history is messed up; the dropdown list always 
contains just one blank item, and I suspect that this empty string is being put 
into the URL bar.
Status: NEW → ASSIGNED
Target Milestone: --- → M19

Comment 1

17 years ago
*** Bug 60332 has been marked as a duplicate of this bug. ***

Comment 2

17 years ago
I see this in any browser window (not just newly opened ones that loaded the
default page). Annoying because there's no way to get the URL back. The only
time this doesn't happen is when the dropdown list has been accessed (using the
up/down arrow keys then scrolls through the URLs contained in that list).

Comment 3

17 years ago
Radha, I can take a look at this when I get some time, if you want.
This is related to the behavior of the GFX widget. Maybe Simon can throw some
light here. I think that I also have another bug similar to this
(Reporter)

Comment 5

17 years ago
What do the mean by the "behaviour of the GFX widget"? The text widgets don't 
respond to up arrow by removing text.

Comment 6

17 years ago
Just to be complete: the down arrow also clears the url bar.
nav triage: 4xp, p4. 
Keywords: 4xp, nsbeta1
Priority: P3 → P4

Comment 8

17 years ago
moving these bugs to History: URLBar
Assignee: radha → alecf
Status: ASSIGNED → NEW
Component: History: Session → History: URLBar

Comment 9

17 years ago
nav triage team:

Marking nsbeta1+
Whiteboard: nsbeta1+

Comment 10

17 years ago
nav triage team:

Putting on the backburner, though we should decided what up and down arrow
SHOULD do for the product. Removing nsbeta1+, marking p5 and future
Priority: P4 → P5
Whiteboard: nsbeta1+
Target Milestone: --- → Future

Comment 11

17 years ago
Created attachment 26127 [details] [diff] [review]
[patch] make sure we have an autocomplete popup first

Comment 12

17 years ago
cc'ing ducarroz for review
Assignee: alecf → blakeross
OS: Mac System 8.5 → All
Hardware: Macintosh → All

Comment 13

17 years ago
r=timeless
please fix tabs in the two lines following your patch
Keywords: approval
Target Milestone: Future → ---
Please wait on my review before check it in...
If I correctly undestand your patch, the keynavigation is responsible for
clearing the URL bar. Therefore your fix is to do keynavigation only when the
popup menu is open. Right?

In this case I will have to refuse this patch as we will lost the posibility of
using autocompletion without dropdown list which can be set with a special
attribute on the input field. The right fix is to avoid keyNavigation when there
is not valid entry.

Comment 16

17 years ago
What attribute is this and why would we ever want to do that?  What could be 
more dangerous (and surprising) than changing a textfield to a completely 
different value, without the possibility of undo, when the user thinks he's 
just navigating the textfield (since that's how most other textfields in the 
product work), and there's no indication that autocomplete is kicking in?

Comment 17

17 years ago
When there are no auto-completions available for a given text field, Up and 
Down should act exactly as if the field didn't do auto-completion at all 
(because it isn't!). On Mac OS, this means go to the beginning/end of the 
field. On other OSes, it means do nothing at all.

When there are auto-completions available, the first Up/Down should open the 
auto-completion menu. The exception is on Mac OS, where the first Up/Down 
should go to the beginning/end of the field, and the second Up/Down should open 
the auto-completion menu. (This opinion is subject to slight modification when 
I finish my auto-complete spec.)
my mistake, the attribut doesn't exist anymore but it's up to the autocomplete
session to decide if it want the popup to show up or not, just set the
result.defaultItemIndex to 0 and the popup wont open.
The key navigation rotate the input value between results and the original input
value. Therefore you can always come back to the original input. Even when the
popup window is show it's a very convenient feature: imagine you type the
begining of a url and then the popup show up with couple of result. Now you
click on the wrong menu item! what you can do? erase part of the url and start
over! no, just use the up/down arrow to select the correct result.
I should have the real fix very soon...

Comment 20

17 years ago
I think I have the `right' fix in hand now, I'm still just not sure about this 
behavior. I prefer what Matthew said -- just reopen the menu.
Created attachment 26374 [details] [diff] [review]
Patch that fixes the navigation feature instead of disabling it

Comment 22

17 years ago
cool, sr=alecf

Comment 23

17 years ago
sorry, I was hasty, I'll wait for the real fix
Blake, what do you want to do with this bug, handing it over to me or you are
still working on it?

Comment 25

17 years ago
I still think the popup should be shown first (that popup-less `feature' isn't 
too great, usability-wise), but passing off to ducarroz to finish this off.
Assignee: blakeross → ducarroz

Updated

17 years ago
Status: NEW → ASSIGNED
Whiteboard: Fix in hand
reassign to hewitt. Joe, I don't know if we still need this patch with the new autocomplete widget...
Assignee: ducarroz → hewitt
Status: ASSIGNED → NEW
(Assignee)

Comment 27

17 years ago
This is fixed by 43189.
Status: NEW → ASSIGNED
Depends on: 43189
Target Milestone: --- → mozilla0.9.1

Comment 28

17 years ago
Themes Triage Team Marking nsbeta1+
Keywords: nsbeta1+

Updated

17 years ago
Keywords: nsbeta1
(Assignee)

Comment 29

17 years ago
fixed
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 30

17 years ago
marking VERIFIED Fixed with 20010515 builds. Up arrow opens the popup...sounds like that was
what was basically decided upon so okay...
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.