User should be warned about "global search and indexer" being enabled on upgrade

RESOLVED WONTFIX

Status

Thunderbird
Search
RESOLVED WONTFIX
9 years ago
a year ago

People

(Reporter: Jochen De Smet, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [wontfix?])

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.4pre) Gecko/20090914 Shredder/3.0b4pre

Since updating to the build above Thunderbird was using in excess of 1.5GB of virtual memory, and seemed to be constantly displaying "Indexing .. of .. messages in .." in the status bar.

Eventually I figured out this was because of the new indexer; disabling it brought memory usage back to the normal +-300MB virtual, 200MB physical.

Since this new feature can make Thunderbird rather unusable, I don't think it shoudl be blindly enabled when a user upgrades.

Reproducible: Always

Steps to Reproduce:
1. Run older TB build
2. Upgrade to current Shredder
3. Start TB
Actual Results:  
TB memory usage goes up and reaches over 1.5GB virtual after +-20 minutes. Indexer is keeping the disk busy during this time.

Expected Results:  
Max memory used should be limited, or indexer should not be enabled by default on upgrade.

My profile has 2 medium-size IMAP accounts ( 1.5GB and 1GB ), a small IMAP account (6MB), and a news & blogs account.

Comment 1

9 years ago
I can confirm that enabled Indexer made Thunderbird very slow, bordering with useless. 

Additionally Indexer did not quit when large unused mail list folder was moved to the trash. It just continued to index trash items :)

Comment 2

9 years ago
Another effect which would be nice to have a warning about is search may return no results or partial results for some significant period of time. Not the same as this bug I know, and may be covered in another bug. But it's related in the sense that there may be some behaviors the user should be informed of.
Version: unspecified → 3.0
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 516884

Comment 4

9 years ago
Ludo, I have to agree with bug 516884 comment #59:
> I'm the reported of the bug that got marked as a dupe of this in the previous
> comment.  However in the new migration assistant I don't see anything about the
> "Global search and indexer", which was the particular feature that bug was
> about. So I'd request that my bug gets unduped [...] since it's not addressed yet.

Disabling the global indexer is not a part of the current migration assistant, thus not a duplicate. On the other hand, this could be possibly implemented for TB 3.1 only as it requires string changes, where it may be of limited value.

Anyway, reopening as a valid request to add this to the migration assistant.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Updated

9 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: x86 → All
Version: 3.0 → Trunk

Comment 5

9 years ago
Or perhaps an "Emergency Brake" icon on the status bar to stop indexing, and reset the pref.

Updated

9 years ago
It doesn't work at all for large installations (continues indexing forever), so a quick test for > 2 GB files/folders total should turn it off by default.  Heck, I'd say even > 1 GB total should be enough for a warning!

Comment 7

8 years ago
Maybe, I should be filing a new bug report.  But after first upgrading I unchecked the "global search and indexer" option.  However, this option doesn't stick between upgrades.  After every upgrade I have to go back to preferences and while it is unchecked I recheck it then uncheck it to go back to my preference for this setting.  I.e. every upgrade turns "global search and indexer" back on (although in the settings it stays unchecked.)

Comment 8

8 years ago
(In reply to comment #7)
> Maybe, I should be filing a new bug report.  But after first upgrading I
> unchecked the "global search and indexer" option.  However, this option doesn't
> stick between upgrades.  After every upgrade I have to go back to preferences
> and while it is unchecked I recheck it then uncheck it to go back to my
> preference for this setting.  I.e. every upgrade turns "global search and
> indexer" back on (although in the settings it stays unchecked.)

Which build are you using?

Comment 9

8 years ago
Hi Micah

I am running: 

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1.9) Gecko/20100317 Lightning/1.0b1 Thunderbird/3.0.4

Problem started when "global search and indexer" was first introduced.

Comment 10

8 years ago
I can confirm this issue in:

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.1.9) Gecko/20100317 Lightning/1.0b1 Thunderbird/3.0.4

It seems to happen intermittently between restarts of Thunderbird, although I can't confirm it at this stage (maybe there's been a few updates recently).

Comment 11

8 years ago
This problem recurs after EVERY update to Thunderbird on Mac. Furthermore, it appears that the only way to turn off Global Search after an update is to turn it on in preferences, restart, turn it off, and then restart again. This is driving me nuts!

Finally, when it is off, there is no x in the search box to clear it out, as there was before this nightmare started. The x should be restored.

Comment 12

6 years ago
Is this problem gone when updating from recent versions of Thunderbird?  Like updating from from current-version - 1 ?

Or are cases still happening like Ben's ...
> It seems to happen intermittently between restarts of Thunderbird, although
> I can't confirm it at this stage (maybe there's been a few updates recently).

Comment 13

6 years ago
I am currently running Thunderbird 13.0.1 on Snow Leopard. For several updates (I'm not sure how many) global search and indexer has not been turned on when I have upgraded. Also, the x in the search box now appears. So it no longer seems to be a problem.

Comment 14

5 years ago
would you agree we are well past the point where this is useful for the bulk of users, and now that we are 3+ years from initial release that the question of whether to do this won't be revisited?
Flags: needinfo?(mconley)
Flags: needinfo?(bwinton)
Whiteboard: [wontfix?]
Yeah, I'ld be in favour of a WONTFIX at this point…
Flags: needinfo?(bwinton)
Done.
Status: NEW → RESOLVED
Last Resolved: 9 years ago5 years ago
Flags: needinfo?(mconley)
Resolution: --- → WONTFIX

Comment 17

a year ago
This is still a problem. 1) The Global Search and Index is still enabled by default and 2) It uses a lot of CPU cycles and RAM. This is rather discouraging for new users of Thunderbird because it makes it look like Thunderbird uses a lot of CPU power even though it’s just a component which can be disabled. People don’t like it when their computer’s fans rev up after opening up a new email client. With Global search and Index enabled, Thunderbird consumes 1.5 cores on my MacBook Pro. With Global Search and Index disabled, my MacBook Pro’s CPU rarely exceeds 60º. It took me a week to figure out how to fix this problem. Most people aren’t going to spend that much time trying to fix a problem with a new email client - they’ll sooner just go back to Apple’s Mail.app or Microsoft Outlook or whatever they were using before. The only reason I persisted is because I want to switch to Linux, and Thunderbird is the best email client for Linux (as far as I know). Global Index and Search really shouldn’t use a ton of CPU power. It should either be fixed, no longer default, or removed from the program.

Comment 18

a year ago
This problem might be exacerbated by a change to use slower Javascript code in a core MIME parsing module.  See https://bugzilla.mozilla.org/show_bug.cgi?id=1055077  (and also https://bugzilla.mozilla.org/show_bug.cgi?id=1284753)
You need to log in before you can comment on or make changes to this bug.