Closed Bug 516506 Opened 12 years ago Closed 12 years ago

Add-on update check (after Firefox update) is busted: "Ci is not defined"

Categories

(Toolkit :: Add-ons Manager, defect)

x86
macOS
defect
Not set
major

Tracking

()

RESOLVED FIXED
mozilla1.9.3a1
Tracking Status
status1.9.2 --- beta1-fixed

People

(Reporter: jruderman, Assigned: mossop)

References

Details

Attachments

(1 file)

JavaScript error: chrome://mozapps/content/extensions/update.js, line 159: Ci is not defined

Spins saying "This may take a few minutes..." forever.  I've seen this with Windows nightlies and Mac debug builds.

http://mxr.mozilla.org/mozilla-central/source/toolkit/mozapps/extensions/content/update.js#193
blocking2.0: --- → ?
Gah, I hate the mac overlay
Assignee: nobody → dtownsend
Blocks: 392180
Attached patch patchSplinter Review
Attachment #400578 - Flags: review?(robert.bugzilla)
Comment on attachment 400578 [details] [diff] [review]
patch

bah... I stopped compiling / running patches that I review.
Attachment #400578 - Flags: review?(robert.bugzilla) → review+
Landed: http://hg.mozilla.org/mozilla-central/rev/b23223d8222b
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9.3a1
Duplicate of this bug: 516663
Comment on attachment 400578 [details] [diff] [review]
patch

Including in the approval request for the bug this blocks
Attachment #400578 - Flags: approval1.9.2?
Attachment #400578 - Flags: approval1.9.2? → approval1.9.2+
Landed on branch: http://hg.mozilla.org/releases/mozilla-1.9.2/rev/7fe137ccdd09
blocking2.0: ? → ---
You need to log in before you can comment on or make changes to this bug.