Browser zoom level is being reset between page loads when browser.zoom.siteSpecific=false

RESOLVED WORKSFORME

Status

()

Core
General
RESOLVED WORKSFORME
8 years ago
8 years ago

People

(Reporter: Jason Tackaberry, Unassigned)

Tracking

({regression})

1.9.2 Branch
x86
Linux
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2a2pre) Gecko/20090914 Namoroka/3.6a2pre

This is a regression from 3.5.

Reproducible: Always

Steps to Reproduce:
1. Set browser.zoom.siteSpecific=false in about:config
2. Visit, say, google.com
3. Increase the zoom level to something noticeably different
4. Click a link in the browser to load another page
Actual Results:  
The browser zoom level reverts to 100%.

Expected Results:  
The browser zoom should not be changed when siteSpecific=false, which is the behaviour in Firefox 3.5 and 3.0.

This causes a regression in NoSquint, the addon I develop.  NoSquint relies on the fact that the browser.markupDocumentViewer.textZoom and browser.markupDocumentViewer.fullZoom will not be modified by Firefox when browser.zoom.siteSpecific=false.
(Reporter)

Updated

8 years ago
Keywords: regression
Version: unspecified → 1.9.2 Branch
(Reporter)

Comment 1

8 years ago
Tried again with nightly from 20091017 and this regression seems to have been fixed.  (I haven't tested since 20090914 so I'm not sure when it was fixed.)

I'll reopen this bug if the problem resurfaces.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED

Updated

8 years ago
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.