[autoconfiguration]automatic mail account setup wizard fails

RESOLVED DUPLICATE of bug 490430

Status

Thunderbird
Account Manager
P1
major
RESOLVED DUPLICATE of bug 490430
8 years ago
8 years ago

People

(Reporter: brandt24, Assigned: bwinton)

Tracking

Bug Flags:
blocking-thunderbird3 +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [no l10n impact])

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.0; Trident/4.0; SLCC1; .NET CLR 2.0.50727; .NET CLR 3.0.30729; .NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.4pre) Gecko/20090913 Shredder/3.0b4pre

Disclaimer: I realize that this might not be a universal thing, so I am just using this opportunity to display how the Wizrd does not work for me.

Reproducible: Always

Steps to Reproduce:
1. Start the automatic mail account setup wizard.
2. Fill in the name, the email, the pw. Tick to remember the pw.
3. The wizard will go to work.
4. It will establish the incoming server, however fails to establish the correct username or the correct port for the SMTP (only port 1025 is allowed in my case).
5. So after having waited a while for it to chew on the outgoing, I finally click Stop and proceed to "Editing config". :))
6. So I fix the username and the outgoing and hit Re-test Configuration.
Actual Results:  
It seems to stay on an eternal quest for looking up my account settings even though I had handpicked those. So I just hit Stop and Cancel.

Expected Results:  
I would have at least expected it to be able to verify the settings that I had entered manually. Also, what is that status message down there (take a look at the screenshot)?
(Reporter)

Updated

8 years ago
Flags: blocking-thunderbird3?
Version: unspecified → 3.0
(Reporter)

Comment 1

8 years ago
Created attachment 400608 [details]
screenshot
Summary: automatic mail account setup wizard fails → [autoconfiguration]automatic mail account setup wizard fails
(Assignee)

Updated

8 years ago
Assignee: nobody → bwinton

Updated

8 years ago
Whiteboard: [no l10n impact]
Sounds like something needs to happen, if it's confirmed.

Blake, can you throw in your 2 cents?
(Assignee)

Comment 3

8 years ago
I've seen something like that while exploring bug 515371, and yeah, we need to handle the less-happy-path cases in the autoconfig a little better.

But at least it's got no l10n impact.  :)

Thanks,
Blake.
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
OS: Windows Vista → All
I'm going to grant blocking on a pessimistic understanding of the bug.  If it turns out hard to fix and not affecting that many users, it may have to wait until 3.next.
Flags: blocking-thunderbird3? → blocking-thunderbird3+
(Assignee)

Comment 5

8 years ago
When I try to reproduce it, I see a bunch of error messages like this:
incominghostdetector	ERROR	curTry undefined, _tryIndex is 6
so it looks like this is a symptom of a larger problem.
Priority: -- → P1
(Assignee)

Comment 6

8 years ago
This looks like the same problem we were seeing in comment #8 of bug 490430, and after applying the patches in that bug, I can no longer reproduce this problem.
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 490430
You need to log in before you can comment on or make changes to this bug.