gloda should optimize frequent operations

RESOLVED DUPLICATE of bug 466246

Status

Thunderbird
Search
RESOLVED DUPLICATE of bug 466246
9 years ago
9 years ago

People

(Reporter: davida, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
right now, AFAIK, when attributes of a message like read/unread, 'starred/unstarred', 'forwarded', 'replied', or tags change, gloda reindexes the whole message (although I think we don't reindex the full-text.  that feels like it could be optimized, with less time spent 'dirty'.

(to say nothing of 'move to archive', which is likely much more complicated)
Already have a bug on this, although given how fast indexing is, I'm somewhat reluctant to pursue this since it seems likely to shoot reasonable extensions in the foot.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 466246
You need to log in before you can comment on or make changes to this bug.