Top menu (File, Edit, View, ect) steals focus when idle for short time period

VERIFIED INVALID

Status

()

Firefox
Menus
VERIFIED INVALID
9 years ago
9 years ago

People

(Reporter: Ryan O'Meara, Unassigned)

Tracking

3.5 Branch
x86
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3 (.NET CLR 3.5.30729)

The top menu tends to steal focus at random times, and very often when I pause typing.  (For example, as I started typing this, I activated a random menu choice because the top menu stole focus).  It is most noticeable on facebook, out of various sites, since it involves entering text in fields a lot.  It is not consistently stealing focus - sometimes it steals it at a pause, other times when I am in the middle of entering a few sentences at a "normal" speed.

Reproducible: Always

Steps to Reproduce:
1.Go to site that requires entry in test fields (Example: facebook, or bug entry form)
2. Attempt to enter text, pause a couple times as you might while gathering your thoughts
3. At some point, the top menu steals focus, and your keystrokes will activate a random menu item
Actual Results:  
Menu bar still stole focus (File menu item is always the one it highlights as having focus initially, until unaware keystrokes activate another menu item

Expected Results:  
The menu bar should not be stealing focus, it should remain where it is (i.e the box I am typing in) until I direct it somewhere else either via keystroke or mouse click

Using Black Gloss 3.5 theme, under dev (Old black gloss not compatible with 3.5) - Still occurs when using default theme
So do you have any addons installed? Please run Firefox in safe mode to check if those could be the cause of this problem: http://support.mozilla.com/kb/Safe+Mode. Or do you have set any global keyboard shortcuts to access menus? We had a similar situation in the past.
(Reporter)

Comment 2

9 years ago
Determined that this is not an issue specific to Firefox - other programs have recently started showing the same behavior.  Likely a vista issue.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
Thanks Ryan. If you are able to find out what is causing this problem please report back so we have a solution if other users see the same thing.
Status: RESOLVED → VERIFIED
Version: unspecified → 3.5 Branch
You need to log in before you can comment on or make changes to this bug.