Closed Bug 516670 Opened 15 years ago Closed 14 years ago

file ownership changed if ff was invoked from within an sudo command

Categories

(Firefox :: General, defect)

x86
Linux
defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: toralf.foerster, Unassigned)

Details

(Whiteboard: [CLOSEME 2011-1-1])

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.3) Gecko/20090911 Gentoo Firefox/3.5.3
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.3) Gecko/20090911 Gentoo Firefox/3.5.3

When I run "$>sudo ~/devel/wireshark/wireshark" click within wireshark at "homepage" then the following 2 files within my users home dir (tfoerste) have the "wrong" owner ship of "root" : cookies.sqlite-journal places.sqlite-journal.

This results in a ff warning, that the bookmark file can't be used b/c another app is using it. Furthermore this might be the root cause that sometimes I've to restore an older backup  to continue to use ff.


Reproducible: Always
Reporter, are you still seeing this issue with Firefox 3.6.12 or later in safe mode? If not, please close. These links can help you in your testing.
http://support.mozilla.com/kb/Safe+Mode
http://support.mozilla.com/kb/Managing+profiles
Also, please consider using the most recent Firefox 4 beta build, your bug may be resolved there.
Whiteboard: [CLOSEME 2011-1-1]
(In reply to comment #1)
> Reporter, are you still seeing this issue with Firefox 3.6.12 ?
No :-)
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.