Floated element overwritten by table content when first child of container

RESOLVED DUPLICATE of bug 14984

Status

()

Core
Layout: Floats
RESOLVED DUPLICATE of bug 14984
8 years ago
8 years ago

People

(Reporter: tamlyn, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US) AppleWebKit/530.5 (KHTML, like Gecko) Chrome/2.0.172.43 Safari/530.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-GB; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3 (.NET CLR 3.5.30729)

Right-floated elements followed by tables are displayed inconsistently depending upon whether the floated element is the first child of its container. In some cases the table clears the float, in others the float is displayed over the table's background but beneath the table text.

Test case http://tamlyn.org/stuff/page.html

I'm not sure what the correct behaviour is since all browsers behave differently in this situation but it seems particularly strange that the display behaviour should depend upon the floated element's siblings. 

Reproducible: Always

Steps to Reproduce:
See test case URL.



Firefox 3.0 has this bug too. I don't have Firefox 2.0 to check. 

In other browsers, Webkit displays all cases like case 1 except case 4 which it wraps correctly. IE 8 displays all like case 2 except case 4 which it also displays correctly. IE7 doesn't even get case 4 right and displays everything like case 2.

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 14984
You need to log in before you can comment on or make changes to this bug.