Google Search provider missing in 3.5.3

VERIFIED INVALID

Status

()

Firefox
Search
VERIFIED INVALID
8 years ago
8 years ago

People

(Reporter: Karthi, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3 (.NET CLR 3.5.30729)

Updated 3.5.2 to 3.5.3. My default search engine was Google and now it is missing and currently my default search engine changed to Yahoo and I am unable to install Google search on any case... Is it a bug?

Reproducible: Always

Steps to Reproduce:
1. Open Firefox
2. Default search engine points to Yahoo & Google is missing
3.
Actual Results:  
Upgraded from 3.5.2 to 3.5.3

Expected Results:  
Should have my default search engine to be Google

Comment 1

8 years ago
this didn't happen to me on my 3 win xp computers or vista computer, are you sure its not in drop down menu?
Karthi, can you please have a look into the search plugin folder in the application directory? Is the google.xml file located there? Do you see any error in the error console (via tools menu)?
(Reporter)

Comment 3

8 years ago
Henrik, there is a file called google.xml in the searchplugin folder. But I am not able to open it. It is saying access denied. I am able to open other files in that folder. 

There are no errors in the error console.

What could be the problem? Is it an issue in my system?
(Reporter)

Comment 4

8 years ago
Got this error after I opened my GMail now. But don't know whether this is related to the above issue or not...

Error: uncaught exception: [Exception... "Operation is not supported"  code: "9" nsresult: "0x80530009 (NS_ERROR_DOM_NOT_SUPPORTED_ERR)"  location: "https://mail.google.com/mail/?ui=2&view=js&name=js&ver=IAd6MtWKi0g.en.&am=!_SV7VRCFDgHpZd_gwew0QuIIfceX2gVDm-YWs5Of Line: 62"]
(Reporter)

Comment 5

8 years ago
Viola... It is working now. I think my antivirus is blocking the file (with name google). Unable to view or edit. I copied the same file from different system and renamed as googl.. It is working fine now. Thanks.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
Karthi, can you please check with application has been locked this file? You can use the process monitor for that. Here an easy tutorial: http://windowsxp.mvps.org/processlock.htm

We should leave it open until we know what's going on here. Thanks.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
(Reporter)

Comment 7

8 years ago
Thanks for the help Henrik. I came to know from my admin that they have blocked all files in the system which have the keyword Google. To make this problem working, i renamed google.xml to googl.xml and it is working like charm. You can very well close this issue. Thanks for the immediate help.
Thanks for your promptly response. Given that fact this bug will be invalid.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → INVALID

Updated

8 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.