Closed Bug 516919 Opened 11 years ago Closed 9 years ago

[autoconfiguration] Mail account setup: Password check should be done earlier, together with autodetection of settings (feels wrong to see green lights for everything in 2nd step and then get error message for 1st step)

Categories

(Thunderbird :: Account Manager, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: bugzilla2007, Unassigned)

References

Details

(Keywords: polish)

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.4pre) Gecko/20090915 Shredder/3.0b4pre

current behaviour:

With quick mail account setup, after entering my details including bad password in 1st step, in 2nd step tb autodetects mail server settings but doesn't check the password. After step 2, UI signals "everything OK" by showing 3 green circles, and a written confirmation "Shredder has found the settings for your email account". So nothing points to the fact I did something wrong in step 1. Only after step 2, I will get an error message about the bad password of step 1. And at the same place where I just read "Shredder has found the settings...", I now read the opposite: "Configuration could not be verified - is the username or password wrong?" (Also note that the username was already given green light, so why should it be wrong now?). This all feels wrong.

expected behaviour:

After entering my details including wrong password, I press enter.
TB checks account settings first (to make sure these get set as good as possible), and after that automatically checks the username/password combination, too. I'll still get green lights for settings that work (pop, smtp), but I'll also get the feedback about the bad username/password combination right now (right after step 1 where I entered the bad password). I guess the feedback could look the same as it does now, with exclamation mark + note next to password field. And obviously, password field should be enabled in that situation for me to correct it, but that's another bug which I will post in a min.

This will make quick setup even quicker in case of wrong password, and more intuitive.
Summary: [autoconfiguration] Mail account setup: Password check should be done earlier, together with autodetection of settings (feels wrong to see green lights for everything in 2nd step and get error message for 1st step) → [autoconfiguration] Mail account setup: Password check should be done earlier, together with autodetection of settings (feels wrong to see green lights for everything in 2nd step and then get error message for 1st step)
Blocks: 506290
Also see bug 506290 comment #2. I agree that a green light should only be shown
if both the connection and the authentication worked out. My suggestion in the
referenced comment was to only ask for the password after the connections have
been established rather than upfront, to make the context of "success" clear to
the user. Since the password-handling procedure was retained as part of the
initial dialog, it should now proceed right after identifying the connections
without the need to click on "Create Account" explicitly.

Maybe for cases where the connection parameters work but authentication failed
should have a different color than either red or green (yellow?).
Keywords: polish
Version: unspecified → Trunk
I agree with comment 1.

There is in fact quite a lot of password and autoconfiguration related errors (https://bugzilla.mozilla.org/buglist.cgi?query_format=specific&order=relevance+desc&bug_status=__open__&product=Thunderbird&content=password) so this issue should get some attention.

For people who are unable to configure an account Thunderbird is useless. We should fix this for them so that they can become TB users.
We first need to get the config right, in order to confirm the login.
- A wrong config will surely result in a login failure.
- We need to first know whether we can use SSL or encrypted passwords, or have the user confirm that using plaintext passwords is OK, before we can send the password over the wire.

So, no, can't fix this.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → WONTFIX
And FWIW, the green lights are gone now (at least for me).
You need to log in before you can comment on or make changes to this bug.