Quadruple clicks performs a zoom in and then a zoom out on the browser

RESOLVED WORKSFORME

Status

Firefox for Android Graveyard
Panning/Zooming
--
major
RESOLVED WORKSFORME
9 years ago
8 years ago

People

(Reporter: aakashd, Unassigned)

Tracking

Details

(Reporter)

Description

9 years ago
Build Id:

Mozilla/5.0 (Windows; U; WindowsCE 5.2; en-US; rv:1.9.2a2pre) Gecko/20090916 Fennec/1.0a3

and

Mozilla/5.0 (Windows; U; WindowsCE 5.2; en-US; rv:1.9.3a1pre) Gecko/20090916
Fennec/1.0a3

and

Mozilla/5.0 (X11; U; Linux armv6l; en-US; rv:1.9.2a2pre) Gecko/20090916
Fennec/1.0b4pre



Steps to Reproduce:
1. Quadruple click on the content window

Actual Results:
Fennec responds by zooming in and out and/or panning depending on if its branch/trunk and device.

Expected Results:
Nothing should happen on a triple and/or quadruple click
Triple and quadruple clicks are just treated like a double-click followed by more clicks.  I don't think we want to modify the code to treat them special or ignore them, as it would add delay to double-click handling.
I agree. We have no action for triple of quad clicks anyway
(Reporter)

Comment 3

9 years ago
I think taking care of possible problems due to user error is a good thing. Especially when people accidentally click 3 times (or if the software thinks the user clicked three times consecutively) and some sort of content is clicked on accidentally.

I agree that the quadruple click scenario is a bit off, but I'm just thinking of possible negative use cases may occur and I think it's a definite possibility.
(Reporter)

Comment 4

9 years ago
This works for me (triple click and very quick quadruple click) on builds:
Mozilla/5.0 (X11; U; Linux armv7l; Nokia N900; en-US; rv:1.9.2b5pre) Gecko/20091203 Firefox/3.6b5pre Fennec/1.0b6pre

and

Mozilla/5.0 (X11; U; Linux armv6l; Nokia N8xx; en-US; rv:1.9.3a1pre) Gecko/20091203 Firefox/3.7a1pre Fennec/1.0b5
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
(Reporter)

Updated

8 years ago
Component: General → Panning/Zooming
You need to log in before you can comment on or make changes to this bug.