Page Loads do not respect visibility of Awesome Bar search entries

VERIFIED FIXED

Status

--
critical
VERIFIED FIXED
9 years ago
5 years ago

People

(Reporter: aakashd, Unassigned)

Tracking

Details

(Reporter)

Description

9 years ago
Build Id:

Mozilla/5.0 (Windows; U; WindowsCE 5.2; en-US; rv:1.9.2a2pre) Gecko/20090916 Fennec/1.0a3

and

Mozilla/5.0 (Windows; U; WindowsCE 5.2; en-US; rv:1.9.3a1pre) Gecko/20090916
Fennec/1.0a3

and

Mozilla/5.0 (X11; U; Linux armv6l; en-US; rv:1.9.2a2pre) Gecko/20090916
Fennec/1.0b4pre


This is a run-off bug from https://bugzilla.mozilla.org/show_bug.cgi?id=513290


Steps to Reproduce:
1. Start a page load ( try pages with heavy content to see this more easily
like www.espn.com )
2. Click on the URL bar during page load to open up the awesome bar results
3. Type a search entry into the field while the page is loading
4. Wait until the page has finished loading

Actual Results:
The awesome bar results will be replaced by the title of the page, but the awesome bar results page is visible

Expected Results:
The search entry in step 3 should still be visible in the url bar.
(Reporter)

Updated

9 years ago
tracking-fennec: --- → ?
Can you reproduce since 513290 has re-landed?
(Reporter)

Comment 2

9 years ago
Nope, bug 513290 looks to have fixed this on builds:

Mozilla/5.0 (Windows; U; WindowsCE 5.2; en-US; rv:1.9.2b1pre) Gecko/20091012 Fennec/1.0a3

and

Mozilla/5.0 (X11; U; Linux armv7l; en-US; rv:1.9.2b1pre) Gecko/20091012
Fennec/1.0b5pre
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
verified on n810 with 20091012 1.0b5pre (1.9.2 branch)
Status: RESOLVED → VERIFIED
(Assignee)

Updated

5 years ago
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.