Open Browser hogs system memory usage and slows system down

RESOLVED INCOMPLETE

Status

()

Firefox
General
--
major
RESOLVED INCOMPLETE
9 years ago
8 years ago

People

(Reporter: L. A., Unassigned)

Tracking

({perf})

3.5 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3 (.NET CLR 3.5.30729)

Each time the browser is left open for any length of time the system memory usage continues to increase to the point that the Firefox browser slows down the entire Windows operating system. Forcing me to CLOSE the Firefox browser if I want to stop the system CPU memory from reaching and staying at 100% CPU Usage. Once I close the Firefox browser and restart it. It's fine for a while. This problem is consistent. 

Reproducible: Always

Steps to Reproduce:
1. Open the Firefox browser
2. Leave Firefox open for extended periods
3. Forced to close Firefox when I need to continue working with active tabs.
Actual Results:  
If I close the Firefox browser and restart it, it's fine for a while. However, if I leave the browser open for a length of time this problem repeats itself and becomes a real nuisance. 

The Firefox browser seems to reset and doesn't effect the operating system for a short time, but if left open for an extended period of time the system memory continues to climb and the higher it goes the slower the entire operating system becomes. 

Expected Results:  
The Firefox browser should not be interfering with the Windows operating system and slowing down all computer functions while open. 

Firefox should not consistently be building on system memory use and HOGGING the CPU's memory to the point that it slows down the entire operating system to the point it is not functional. If left unattended for any length of time it slows the operating system to the point that everything freezes and stops functioning for several minutes between keystroke or mouse clicks.

Comment 1

9 years ago
I've not noticed a CPU lag, but it eats my RAM when left open for more than an hour, or two.
(Reporter)

Comment 2

9 years ago
(In reply to comment #1)
> I've not noticed a CPU lag, but it eats my RAM when left open for more than an
> hour, or two.

Am I seeing that I am not alone with this issue? Have you suggestions or possibly a 'solution' for this?

Comment 3

9 years ago
do you see this started in safe mode?
 https://support.mozilla.com/en-US/kb/Safe+Mode
with a new profile?
 https://support.mozilla.com/en-US/kb/Managing+profiles?s=new%20profile
Severity: critical → major
Keywords: perf
Version: unspecified → 3.5 Branch

Comment 4

8 years ago
=> incomplete due to no response
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED

Updated

8 years ago
Resolution: FIXED → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.