If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Date column shows 'unknown' in List View

RESOLVED INVALID

Status

Mozilla Labs
Snowl
--
major
RESOLVED INVALID
8 years ago
8 years ago

People

(Reporter: remschi, Unassigned)

Tracking

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.14) Gecko/2009090216 Ubuntu/8.04 (hardy) Firefox/3.0.14
Build Identifier: 

When you 
1. Subscribe http://www.pro-linux.de/backend/pro-linux.rdf
2. then open the List View
3. and finally look at the date column of the "Pro-Linux" source you will see every entry lists the date 'unknown'

I had a quick look if, and if yes, in which format/pattern the date of the the entries of the feed is.

And YES there is a date for each entry in the xml which look like this one here:
<pubDate>Wed Sep 16 19:02:14 2009</pubDate>

So what's the problem here?
What I think:
Is the format of this date of the source wrong 
OR can snowl not parse this date (or does snowl parse it wrong)???

I found out most of the other sources I have subscribed use this date format:
Wed, 16 Sep 2009 17:32:43 +0200

And just for more detailed Information (maybe it helps?) here is the header of the pro-linux.rdf
<?xml version="1.0" encoding="ISO-8859-1"?>
<!DOCTYPE rss PUBLIC "-//Netscape Communications//DTD RSS 0.91//EN"
"http://www.rssboard.org/rss-0.91.dtd">
<rss version="0.91">

Is this the fault of snowl OR from the site because they maybe don't provide the right date-time format?



THE BIG PROBLEM IS THIS RUINS THE WHOLE LIST BECAUSE YOU CAN'T SORT BY DATE CORRECTLY!!!

Reproducible: Always

Steps to Reproduce:
1. Subscribe http://www.pro-linux.de/backend/pro-linux.rdf
2. Open List View
3. Look at the date column of the "Pro-Linux" source. Every entry lists the date 'unknown'
(Reporter)

Updated

8 years ago
Version: unspecified → 0.3

Comment 1

8 years ago
the feed's date you listed is indeed invalid rss 0.91 pubDate (rfc822) format.  please contact the site and have them make the trivial fix (it's even a tech oriented site).

i have no issue sorting; the 'invalid' text is appropriate for a malformed date.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID

Comment 2

8 years ago
meaning 'unknown' rather..
You need to log in before you can comment on or make changes to this bug.