Closed Bug 517091 Opened 11 years ago Closed 11 years ago

Don't do an expensive asynchronous RequestDecode() if there's already an active full decoder

Categories

(Core :: ImageLib, defect)

x86
macOS
defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: bholley, Assigned: bholley)

Details

(Whiteboard: [decodeondraw])

Attachments

(1 file)

According to my local Tp4 runs, this seems to be the (or a major) source of the regression in bug 516331. Pushing to try in a moment to verify.
Whiteboard: [decodeondraw]
Attached patch patch v1Splinter Review
added the patch. Pushed to try as ea0dc4e75f07, along with a patch to re-enable discarding so that we can see if this fixes the regression.
Attachment #401129 - Flags: review?(joe)
Comment on attachment 401129 [details] [diff] [review]
patch v1

this seems to fix the problem on try. It's hard to get a decent baseline, but it looks like turning on discarding with this patch makes Tp4 go 660->690, which is to be expected given the perf hit involved with discarding in general (see bug 502694 and bug 517119).

flagging joe for review.
Comment on attachment 401129 [details] [diff] [review]
patch v1

Add to the "if we're within the decoder" comment something talking about being reentrant, for clarity.
Attachment #401129 - Flags: review?(joe) → review+
http://hg.mozilla.org/mozilla-central/rev/54f161dc183a

resolving fixed.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.