Table with border="0", but CSS to make cell border show doesn't always display

VERIFIED DUPLICATE of bug 25228

Status

()

defect
P3
normal
VERIFIED DUPLICATE of bug 25228
19 years ago
19 years ago

People

(Reporter: cmanske, Assigned: attinasi)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Reporter

Description

19 years ago
In Composer, the primary difference in the display is that we must show table
borders even if user has set <table border="0"> We try to do this with CSS:
table[empty-cells],
  table[border="0"],
  table[border="0"] td, table[border="0"] th {
  border: 1px dotted red;
}
in an EditorContent.css.
I will attach a test file that shows that the cell border doesn't display.
Reporter

Comment 2

19 years ago
Ok, now here's where it gets interesting:
Load Composer, insert a table (degfault size is OK) but change "border" to "0"
Again, the cells in the table don't show a border.
But insert a table again, keep the default border="1". This table has visible
border of 2px. Click on Table toolbar button to bring up Table Properties
dialog, go to the "Table" tab, and change border to "0", hit OK.
Now, the cell borders display! You can type in the cells and relayout doesn't
affect them.
But if you do any operation that inserts new cells (such as using Tab to move
from cell to cell and after the lower right cell a row will automatically be
inserted), the cell border will disappear!
In any of the display situations, you can cause all of the cell borders to
reappear by changing to HTML Source mode via the View menu or toolbar at bottom
of editor (may not be visible - you can turn it on via View | Toolbars | Edit
Mode toolbar and it will stay on). You can examine the source code here to
be sure the border values look correct. Switch back to "Normal" edit mode and
now all the red dotted cell borders are visible!
Switching from HTML Source to Normal simple reinserts all of the body content
into the existing DOM content tree using the parser. What is real weird is that
saving the file, then reopening it does *not* display the cell borders!
If theres something wrong with my CSS or you can find a quick fix, I think this
should be looked at for beta3
Keywords: nsbeta3
Assignee

Comment 3

19 years ago
CC'd karnaze. Chris, this sounds like it might have to do with using 
DidSetStyleContext to deal with the border='0' attribute. What do you think?

Status: NEW → ASSIGNED

Comment 4

19 years ago
This is a dupe of bug #25228? or at least has something to do with it...
Assignee

Comment 5

19 years ago
James, you are right, it is a dup of bug 25228. Thanks.

NOTE: there is some interesting stuff in here from Charley about how the borders 
sometimes do and sometimes don't work - this could be useful in understanding 
the problem...

*** This bug has been marked as a duplicate of 25228 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE

Comment 6

19 years ago
This is a dup of bug 25228:Tables with TD CSS borders and border=0 don't show
borders
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.