window freezes while dragging tab and simultaneously a HTTP Auth. prompt props

VERIFIED DUPLICATE of bug 100180

Status

()

Firefox
Tabbed Browser
--
major
VERIFIED DUPLICATE of bug 100180
8 years ago
8 years ago

People

(Reporter: karthikatindia, Unassigned)

Tracking

3.5 Branch
x86
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3 (.NET CLR 3.5.30729)

browser window freeze when I dragged tab to different position and at the same time a HTTP Auth. prompt props up for user input. the window focus is neither on the prompt nor finishing the drag drop action. the window just freeze and stopped responding to any events further on.

Reproducible: Didn't try

Steps to Reproduce:
1. drag a tab to different position
2. setup condition(loading a site) such that, you get HTTP Auth prompt props up while you drag the tab and yet to drop it
3.in the time the tab is dragged and simultaneous HTTP Auth prompt
Actual Results:  
window freezes and stopped responding to user interaction


Expected Results:  
tab drag action should be canceled and focus should be on HTTP Auth prompt text field


Build platform
target
i686-pc-mingw32

Build tools
Compiler 	Version 	Compiler flags
cl 	14.00.50727.762 	-TC -nologo -W3 -Gy -Fdgenerated.pdb -DNDEBUG -DTRIMMED -Zi -UDEBUG -DNDEBUG -GL -wd4624 -wd4952 -O1
cl 	14.00.50727.762 	-GR- -TP -nologo -Zc:wchar_t- -W3 -Gy -Fdgenerated.pdb -DNDEBUG -DTRIMMED -Zi -UDEBUG -DNDEBUG -GL -wd4624 -wd4952 -O1

Configure arguments
--enable-application=browser --enable-update-channel=release --enable-update-packaging --enable-jemalloc --enable-official-branding --with-crashreporter-enable-percent=10
(Reporter)

Comment 1

8 years ago
Created attachment 401196 [details]
error state
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 100180
V.Duplicate
Severity: critical → major
Status: RESOLVED → VERIFIED
Version: unspecified → 3.5 Branch
You need to log in before you can comment on or make changes to this bug.