Closed Bug 517264 Opened 11 years ago Closed 11 years ago

maemo fennec no longer launching on mozilla-central as of 9/17

Categories

(Toolkit :: Add-ons Manager, defect, critical)

ARM
Maemo
defect
Not set
critical

Tracking

()

VERIFIED FIXED
Tracking Status
status1.9.2 --- beta1-fixed

People

(Reporter: aki, Assigned: mfinkle)

References

Details

Attachments

(1 file)

The n810 test devices were last able to launch Fennec with the build off of http://hg.mozilla.org/mozilla-central/rev/3c3c2efab7e8 and http://hg.mozilla.org/mobile-browser/rev/cb8d30f915c4 .  On the next cycle, they were unable to launch Fennec, as well as the following cycle.

Since http://hg.mozilla.org/mozilla-central/rev/3079370d6597 is a locale-specific checkin, I'm suspecting http://hg.mozilla.org/mozilla-central/rev/c41850fecc96
(In reply to comment #1)
> I suspect:
> http://mxr.mozilla.org/mozilla-central/source/toolkit/mozapps/extensions/src/nsExtensionManager.js.in#2176
> 
> which will throw if the pref is not set

Fun, I expected that that pref was always meant to be set but I see that isn't so. If you want to give a patch that defaults that to "classic/1.0" I'll r+ it in a heartbeat.
Attached patch patchSplinter Review
Adds a try/catch around the code
Assignee: nobody → mark.finkle
Attachment #401239 - Flags: review?(dtownsend)
Attachment #401239 - Flags: review?(dtownsend) → review+
Component: Linux/Maemo → General
QA Contact: maemo-linux → general
Duplicate of this bug: 517210
pushed:
http://hg.mozilla.org/mozilla-central/rev/39174e9a7a25
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
talos cycles are able to launch fennec now.
Status: RESOLVED → VERIFIED
Component: General → Add-ons Manager
Product: Fennec → Toolkit
QA Contact: general → add-ons.manager
Comment on attachment 401239 [details] [diff] [review]
patch

a192=me - simple robustness fix that lets fennec work again.
Attachment #401239 - Flags: approval1.9.2+
You need to log in before you can comment on or make changes to this bug.