parentID can be null or missing

VERIFIED FIXED in 1.4

Status

support.mozilla.org
Forum
--
major
VERIFIED FIXED
9 years ago
9 years ago

People

(Reporter: stephend, Assigned: jsocol)

Tracking

unspecified

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: aaq sumo_only)

Attachments

(1 attachment, 1 obsolete attachment)

I've found a case where parentID can be missing or null, as seen here:

http://screencast.com/t/CFetQ9lw4

Wanted to get the bug filed -- I'll back-fill the steps to reproduce next.
STR:

1. Load https://support-stage.mozilla.org/tiki-view_forum.php?locale=en-US&forumId=1
2. Click "Ask a new question"
3. Choose "Problems with settings, bookmarks, passwords or other data stored by Firefox" and click "Next step"
4. Type just a space and click "Next step"
5. Type the captch, click "Next step"
6. Advance through the warnings until you see "Oops! A similar thread already exists!", and then click on "Click here to see it" (https://support-stage.mozilla.org/tiki-view_forum_thread.php?forumId=1&comments_parentId=)
Assignee: nobody → james
(Assignee)

Updated

9 years ago
Whiteboard: aaq
(Assignee)

Comment 2

9 years ago
Created attachment 401994 [details] [diff] [review]
patch, v1

Looks like just a missing line break.
Attachment #401994 - Flags: review?(laura)

Updated

9 years ago
Attachment #401994 - Flags: review?(laura) → review+
(Assignee)

Comment 3

9 years ago
r52132 / r52133
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
I can no longer reproduce the "Oops!  A similar thread already exists!" error message (which is a necessary precondition), so I can't verify this change.
(Assignee)

Comment 5

9 years ago
I can reproduce the similar thread error, but the output doesn't seem to be consistent.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 6

9 years ago
Created attachment 402237 [details] [diff] [review]
patch, v2

I'm not entirely sure why the previous patch ever worked for me? This one works for me. Of course, I'm also pretty sure the last one did before I committed it, so...
Attachment #401994 - Attachment is obsolete: true
Attachment #402237 - Flags: review?(laura)

Comment 7

9 years ago
Comment on attachment 402237 [details] [diff] [review]
patch, v2

It worked for me too - you are not going crazy.  Maybe we backed something out that re-broke it?  But this works.
Attachment #402237 - Flags: review?(laura) → review+
(Assignee)

Comment 8

9 years ago
r52193 / r52194
Status: REOPENED → RESOLVED
Last Resolved: 9 years ago9 years ago
Resolution: --- → FIXED
Verified FIXED; reproduced the "duplicate/similar thread exists" error, clicked through, and no longer see this error.
Status: RESOLVED → VERIFIED

Updated

9 years ago
Whiteboard: aaq → aaq sumo_only
You need to log in before you can comment on or make changes to this bug.