Closed Bug 517290 Opened 12 years ago Closed 12 years ago

Abstract setting JSScopeProperty::parent, add cycle-detection assertions

Categories

(Core :: JavaScript Engine, defect)

defect
Not set
normal

Tracking

()

RESOLVED INVALID

People

(Reporter: Waldo, Assigned: Waldo)

References

Details

I seem to have a cycle in a patch I'm working on, and no assertions fired.  We should have some, ones to detect length-one cycles that always check, and some behind default-off #ifdefs that detect arbitrary-length cycles.
What did you change to cause a cycle?

/be
Setting parent is already abstracted by InsertPropertyTreeChild.

/be
Hm, so it is.  I'm not sure yet; it's something in the defineProperty patch -- I think.  But that doesn't make much sense since I'm not doing anything particularly unusual.  More investigation yet needed.
Can't reproduce the original problem, think I have a handle on what might have caused it, this bug's DOA.
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.