Donations page sends base64NONSENSE data to the paypal page

VERIFIED FIXED in 5.1

Status

VERIFIED FIXED
9 years ago
3 years ago

People

(Reporter: mgalli, Assigned: clouserw)

Tracking

unspecified
x86
All

Details

Attachments

(3 attachments)

(Reporter)

Description

9 years ago
I don't know how come but I was able to get a donation even after AMO sent this base64.. chunk of data as being the purpose of the donation.

* Attached image has the problem

How to reproduce: 

* Go to my addon page: https://addons.mozilla.org/pt-BR/firefox/addon/10284 
* Click donate
* Check the problem
* Feel free to donate ( optional  but not required to check this bug : )
(Reporter)

Comment 1

9 years ago
Created attachment 401310 [details]
Donate page problem
This is what we send to paypal for the problem addon:

Location: https://www.paypal.com/cgi-bin/webscr?cmd=_donations&&item_name=Contribui%C3%A7%C3%A3o+para+PinkTheme+Pink+Pack+&item_number=6ade21f323099145eb3392ae240353ea

This is what we send for Threadbubble, which has no problems:
Location: https://www.paypal.com/cgi-bin/webscr?cmd=_donations&item_name=Contribution+for+ThreadBubble&item_number=b3cfa16d6ab0e360360805626976d891

(I took out the unimportant parts.)

Notice the unicode escaping for the PinkTheme item_name since I went to Paypal 
from /pt-BR/.  I'm guessing that's where Paypal is dying since it works fine for
en-US (PinkTheme looks fine when going from en-US).

I'd like to believe that we're doing the right thing with that URL encoding and
Paypal is just dumb, since that would support my grand worldview.  Can anyone 
confirm?
(Reporter)

Updated

9 years ago
OS: Mac OS X → All
(Reporter)

Comment 3

9 years ago
Pinged some info about this bug to the paypal feedback forms channel.
(Assignee)

Comment 4

9 years ago
Created attachment 401851 [details] [diff] [review]
tell paypal we're using utf-8
Assignee: nobody → clouserw
Attachment #401851 - Flags: review?(jbalogh)
Comment on attachment 401851 [details] [diff] [review]
tell paypal we're using utf-8

gd unicode!
Attachment #401851 - Flags: review?(jbalogh) → review+
(Assignee)

Comment 6

9 years ago
r51976
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → 5.1
Created attachment 404469 [details]
Post-fix screenshot
Verified FIXED on https://addons.mozilla.org/pt-BR/firefox/addons/contribute/10284?source=addon-detail.
Status: RESOLVED → VERIFIED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.