"Unexpected" behavior of 'J' shortcut on MarkedAsJunk messages

RESOLVED WORKSFORME

Status

SeaMonkey
MailNews: Message Display
RESOLVED WORKSFORME
9 years ago
4 years ago

People

(Reporter: sgautherie, Unassigned)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a5pre) Gecko/20070515 SeaMonkey/1.5a] (nightly) (W2Ksp4)
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.1.4pre) Gecko/20090917 SeaMonkey/2.0pre] (nightly) (W2Ksp4)

Tested in my IMAP (MarkAsDeleted model) Inbox folder:

1- Mark a message as Junk.
2- (Re)Select it.
3- Press 'J' (MarkAsJunk).
3r- Message keeps Junk status but is un-deleted.

This behavior is specific to the key binding,
as using the NotJunk icon from the toolbar works fine (as using Shift-J).

I assume 'J' should just do nothing on an already MarkedAsJunk message.

NB: Though maybe I would like 'J' to act as a toggle, marking/unmarking depending on the message status!? (But I guess this would not be this bug...)
Flags: wanted-seamonkey2.0?

Comment 1

9 years ago
I believe this is actually something in the backend.

J is always mark as junk, Shift+J is mark as not junk, just look into the "Mark" submenu of the "Message" menu and you find both there.

The (potential) bug I see reported here is actually marking as junk removing the deleted flag. I wonder if rkent knows something about that.

Comment 2

9 years ago
Sounds likely; manual mark as junk is obviously configured here to delete messages. I can't remember how manual mark as junk actually deletes the messages, but when using the IMAP delete model the delete key acts as a toggle.

Comment 3

9 years ago
Canceling wanted as the bug itself isn't even fully clear.
Flags: wanted-seamonkey2.0?

Comment 4

5 years ago
Do you still  see this?
Flags: needinfo?(sgautherie.bz)
(Reporter)

Comment 5

4 years ago
(Sorry for the very long delay.)

[Mozilla/5.0 (Windows NT 6.0; rv:29.0) Gecko/20100101 Firefox/29.0 SeaMonkey/2.26]

With(/without) "When I mark as junk ... Delete" option, I can't reproduce.

R.WorksForMe
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(bugzillamozillaorg_serge_20140323)
Resolution: --- → WORKSFORME
(Reporter)

Comment 6

4 years ago
(In reply to Serge Gautherie (:sgautherie) from comment #0)
> [Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.1.4pre)
> Gecko/20090917 SeaMonkey/2.0pre] (nightly) (W2Ksp4)

[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14] (W2Ksp4)

Ftr, with (needed) "When I mark messages as junk : Delete them" option, I can reproduce.


(In reply to Serge Gautherie (:sgautherie) from comment #5)

> [Mozilla/5.0 (Windows NT 6.0; rv:29.0) Gecko/20100101 Firefox/29.0
> SeaMonkey/2.26]

(Ftr, I don't think this is a "W2000 vs WVista" issue.)

> R.WorksForMe
You need to log in before you can comment on or make changes to this bug.