mochitest-plain: random timeout during test_menuchecks.xul

VERIFIED DUPLICATE of bug 512296

Status

()

Core
XP Toolkit/Widgets: Menus
VERIFIED DUPLICATE of bug 512296
9 years ago
8 years ago

People

(Reporter: dholbert, Unassigned)

Tracking

1.9.2 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [test which aborts the suite], URL)

(Reporter)

Description

9 years ago
The test "test_menuchecks.xul" timed out (and aborting the mochitest-plain suite) on a Linux 1.9.2 tinderbox twice today.  This was in two consecutive cycles, and the only "guilty" changeset was a trivial build change ("Remove unneeded buildid directory", changeset c5e339ec8304)

The failing cycles were:
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox3.6/1253209334.1253216783.2554.gz
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox3.6/1253233587.1253242221.12648.gz

The failures look like:
{
89531 INFO Running /tests/toolkit/content/tests/widgets/test_menuchecks.xul...

command timed out: 300 seconds without output, killing pid 5235
process killed by signal 9
}

I initially mentioned this in bug 506038 comment 35, thinking it might be related (since that bug's about a similar timeout on a test in the same directory).  However, now that it's happened twice, I'm giving this its own bug.
(Reporter)

Comment 1

9 years ago
Of course, it's possible the box just needs a kick, too.  I guess we'll see after the next cycle completes.
Whiteboard: [test which aborts the suite] [orange]
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox3.6-Unittest/1253607920.1253611221.16848.gz
OS X 10.5.2 mozilla-1.9.2 test mochitests on 2009/09/22 01:25:20
OS X 10.5.2 mozilla-1.9.2 unit test on 2009/09/23 23:31:34
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox3.6/1253773894.1253783129.20640.gz
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox3.6-Unittest/1253883071.1253886214.12006.gz
OS X 10.5.2 mozilla-1.9.2 test mochitests on 2009/09/25 05:51:11
{
27807 INFO Error: Unable to restore focus, expect failures and timeouts.
90408 ERROR TEST-UNEXPECTED-FAIL | /tests/toolkit/content/tests/widgets/test_menuchecks.xul | Test timed out.
90411 INFO Error: Unable to restore focus, expect failures and timeouts.
90415 ERROR TEST-UNEXPECTED-FAIL | /tests/toolkit/content/tests/widgets/test_menulist_keynav.xul | letter pressed command event fired - got false, expected true
[...]
}
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox3.6-Unittest/1253964823.1253967877.17898.gz
OS X 10.5.2 mozilla-1.9.2 test mochitests on 2009/09/26 04:33:43

There seem to be two different types of failure here: the test times out and the process is killed as observed by Daniel; and the case where the test times out and is followed by a large number of test failures, as in this log, and Serge and Marco's logs.
This is a dupe of bug 512296, which was fixed on trunk. Someone should land it on branch I guess, I'll request approval.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 512296
V.Duplicate
No longer blocks: 438871
Status: RESOLVED → VERIFIED
Whiteboard: [test which aborts the suite] [orange] → [test which aborts the suite]
You need to log in before you can comment on or make changes to this bug.