If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Awesomebar doesn't lose focus when user clicks on a item in the awesomebar search results list

VERIFIED FIXED

Status

Fennec Graveyard
General
VERIFIED FIXED
8 years ago
7 years ago

People

(Reporter: jukka.miettinen, Unassigned)

Tracking

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.14) Gecko/2009090216 Ubuntu/8.10 (intrepid) Firefox/3.0.14
Build Identifier: 1.9.2a1pre

Awesomebar doesn't loose focus when user clicks on a item in the awesomebar search results list

Reproducible: Always

Steps to Reproduce:
1. Click on awesomebar
2. Enter some text 
3. Click on any result
Actual Results:  
Fennec tries to load the URL that user selected, awesomebar doesn't loose focus

Expected Results:  
Fennec tries to load the URL that user selected, awesomebar does loose focus

This is issue might cause problems when using other input methods.
Summary: Awesomebar doesn't loose focus when user clicks on a item in the awesomebar search results list → Awesomebar doesn't lose focus when user clicks on a item in the awesomebar search results list
hmm. I'm hope this to be resolved by bug 513290
Reporter, can you verify this bug was fixed with the latest beta of fennec?
This works for me on builds and Vivien has mentioned a patch that might have fixed this, so setting to resolved:fixed :
Mozilla/5.0 (X11; U; Linux armv7l; Nokia N900; en-US; rv:1.9.2b4pre) Gecko/20091125 Firefox/3.6b4pre Fennec/1.0b6pre

and

Mozilla/5.0 (X11; U; Linux armv6l; Nokia N8xx; en-US; rv:1.9.3a1pre) Gecko/20091125 Firefox/3.7a1pre Fennec/1.0b5
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED

Updated

7 years ago
Component: Linux/Maemo → General
OS: Linux → Linux (embedded)
QA Contact: maemo-linux → general
Hardware: All → ARM
You need to log in before you can comment on or make changes to this bug.