Awesomebar reacts to clicks only

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
9 years ago
8 years ago

People

(Reporter: jukka.miettinen, Unassigned)

Tracking

Trunk
ARM
Maemo

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.14) Gecko/2009090216 Ubuntu/8.10 (intrepid) Firefox/3.0.14
Build Identifier: 1.9.2a1pre

User can select text from the awesomebar. This is working fine and intended behavior.

When now typing something to replace the selected text the awesomebar search results view is not displayed. This is not good as the user will probably want to e.g. enter this changed text into a search engine.

There is further no "go" button displayed, so the user can not actually go to any URL he had entered this way.

Reproducible: Always

Steps to Reproduce:
1. Select text on awesomebar
2. Type something to replace the selected text
Actual Results:  
Awesomebar search results view is not displayed. And there is no "go" button displayed, so the user can not actually go to any URL he had entered this way.

Expected Results:  
Awesomebar search results view should be displayed. Go button is visible in that view.
This works for me on builds:

Mozilla/5.0 (X11; U; Linux armv7l; Nokia N900; en-US; rv:1.9.2b4pre) Gecko/20091125 Firefox/3.6b4pre Fennec/1.0b6pre

and

Mozilla/5.0 (X11; U; Linux armv6l; Nokia N8xx; en-US; rv:1.9.3a1pre) Gecko/20091125 Firefox/3.7a1pre Fennec/1.0b5
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME

Updated

8 years ago
Component: Linux/Maemo → General
OS: Linux → Linux (embedded)
QA Contact: maemo-linux → general
Hardware: All → ARM
You need to log in before you can comment on or make changes to this bug.