Last Comment Bug 517509 - drag and drop rss feed link from browser to folderpane does nothing
: drag and drop rss feed link from browser to folderpane does nothing
Status: RESOLVED FIXED
[no l10n impact]
: regression
Product: Thunderbird
Classification: Client Software
Component: Mail Window Front End (show other bugs)
: Trunk
: All All
: -- minor (vote)
: Thunderbird 13.0
Assigned To: alta88
:
Mentors:
: 256777 358648 383633 516929 613812 (view as bug list)
Depends on:
Blocks: 414038 515237
  Show dependency treegraph
 
Reported: 2009-09-18 11:13 PDT by ovidiu
Modified: 2012-02-21 05:30 PST (History)
14 users (show)
dmose: blocking‑thunderbird3-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
patch (662 bytes, patch)
2012-02-14 07:39 PST, alta88
no flags Details | Diff | Splinter Review
patch (1.12 KB, patch)
2012-02-15 11:45 PST, alta88
mozilla: review+
Details | Diff | Splinter Review

Description ovidiu 2009-09-18 11:13:34 PDT
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.4pre) Gecko/20090915 Thunderbird/3.0b4

Drag and drop rss link from FF to folderpane simply never works

STR
-have TB with a blog and feeds account
-have a page with rss link
-drag from browser to account or folder under Blogs

a.it appears possible, highlight etc but nothing happens
b.it appears possible,""http...link" not a valid feed" brief status bar message
[same works if added manually, same works if dragged into the manage/add url field]

there are several older bugs to touch this and some new ones, but I don't seam to find precisely this, though it surely is out there [thus dupeme!]
 Bug 252859, Bug 256777, Bug 516929 and others
Comment 1 Joe Sabash [:JoeS1] 2009-09-18 17:45:21 PDT
Some testing with WinXP
Open a page in firefox with http://pearce.org.nz/2009/09/ogg-video-seek-performance-improvements.html

Look at the feed link in the lower right hand corner. It has the structure:
<a target="_blank" href="http://pearce.org.nz/atom.xml" type="application/atom+xml">Atom</a>

Attempt to drag and drop that link into News and Blogs and you get:
"http://pearce.org.nz/atom.xmlAtom" could not be found in the status bar.

It seems the link text "Atom" has been appended to the feed URL
Comment 2 Phil Ringnalda (:philor, back in August) 2009-09-18 18:52:14 PDT
That I'm sure I've seen mention of, but it would be an enormous help if someone could find the one-day window in nightly builds when it started happening.
Comment 3 Gary Kwong [:gkw] [:nth10sd] 2009-09-22 01:18:35 PDT
This seems WFM in Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1.4pre) Gecko/20090915 Thunderbird/3.0b4

Wayne, what about Vista?
Comment 4 ovidiu 2009-09-22 02:41:12 PDT
XP on another machine, brand new profile only rss folder and some subscriptions

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.3pre) Gecko/20090810 Shredder/3.0b4pre
and then
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.4pre) Gecko/20090921 Shredder/3.0pre



Error: not well-formed
Source File: http://www.nytimes.com/services/xml/rss/nyt/Dance.xmlDance
Line: 1, Column: 62
Source Code:
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN"/>

where the actual link (as in FF) is 
http://www.nytimes.com/services/xml/rss/nyt/Dance.xml
not
http://www.nytimes.com/services/xml/rss/nyt/Dance.xmlDance

same works like a charm if dragged into the Feed Subscriptions panel and brings the field with the correct url and folder to choose. So there's a difference between subscribe window and the folderpane in the way they interpret the dropped address.
Comment 5 ovidiu 2009-09-22 02:43:54 PDT
oh, fwiw, beta3 not working also
Comment 6 Wayne Mery (:wsmwk, NI for questions) 2009-09-22 06:52:12 PDT
using 090922 nightly and http://pearce.org.nz/atom.xml I get 

Error: syntax error
Source file: http://pearce.org.nz/atom.xmlAtom
Line: 1, Column: 50
Source code:
<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
Comment 7 cantalou 2009-09-24 10:28:58 PDT
With Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.9.1b1pre) Gecko/20081006 Shredder/3.0a3 ID:20081006095651

Drag and Drop works

With Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.9.1b3pre) Gecko/20081204 Thunderbird/3.0b1 ID:20081204115318

Drag and Drop is not working
Comment 8 Dan Mosedale (:dmose) 2009-09-24 14:36:25 PDT
We'd love to get this, but wouldn't block on it, since it's not a regression from Tb2.  Note that the current regression windows is very wide, doing a binary search on builds to narrow it down to (ideally) a particular build would be very helpful.
Comment 9 Dan Mosedale (:dmose) 2009-09-24 15:35:16 PDT
To avoid confusion, the reasoning here is that as far as we know, while this was a regression from an alpha, it didn't work in Tb2.
Comment 10 cantalou 2009-09-24 23:40:31 PDT
=> with version 2.0.0.23 (20090812)

Drag & Drop works

=> with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2pre) Gecko/20081112 Shredder/3.0b1pre ID:20081112031406

Drag & Drop works

=> with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2pre) Gecko/20081113 Shredder/3.0b1pre ID:20081113031301

Drag & Drop doesn't work
Comment 11 Ludovic Hirlimann [:Usul] 2009-09-24 23:55:37 PDT
(In reply to comment #8)
> We'd love to get this, but wouldn't block on it, since it's not a regression
> from Tb2.  Note that the current regression windows is very wide, doing a
> binary search on builds to narrow it down to (ideally) a particular build would
> be very helpful.

It was cantalou first or second contribution to QA yesterday and he ran out of time before completing hence the initial wide window.

(In reply to comment #10)
> => with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2pre)
> Gecko/20081112 Shredder/3.0b1pre ID:20081112031406
> 
> Drag & Drop works
> 
> => with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2pre)
> Gecko/20081113 Shredder/3.0b1pre ID:20081113031301

Thanks for finishing the work !

Looking at http://hg.mozilla.org/comm-central/pushloghtml?startdate=2008-11-12&enddate=2008-11-13 this looks like a regression from bug 414038.
Comment 12 David Ascher (:davida) 2009-09-25 00:00:57 PDT
jminta, if you have any ideas, jump in =)

(cantalou: thanks indeed -- getting a narrow regression window is super helpful)
Comment 13 alta88 2012-02-14 07:39:47 PST
Created attachment 597026 [details] [diff] [review]
patch


incorrect data transfer type is being used, just the url is wanted.
Comment 14 David :Bienvenu 2012-02-14 09:47:38 PST
OK, my problem is that I can't drag drop to the news and blogs line, i.e., the top level container, which is what I want to do. I can't do that with or without this patch. This is on Windows; I'm dragging the xml links from this page - http://sportsillustrated.cnn.com/services/rss/

If I go into the subscribe UI, and have the top level News and Blogs line selected, I can't get the Add button to be enabled either.
Comment 15 alta88 2012-02-14 10:24:29 PST
that's because that specific xml link is being assigned a data transfer type of "application/x-moz-file", and that type is handled before the feed code in the drop() function in the folderpane code.  it's not related to bug 716706.  dragging the link from, say, https://addons.mozilla.org/en-us/thunderbird/extensions/?sort=featured page should work.

this patch fixes the second problem of a url string being incorrectly joined with \n+title, thus being a bad url when passed to the feed interface.

dragging the same xml link onto the Subscribe dialog root folder works for me.  if a feed is selected, Add is disabled, if a folder is selected, Add is enabled - for pasting a url.  for dnd, the Add button or current selection is not relevant.
Comment 16 alta88 2012-02-14 11:51:07 PST
more specifically, "application/x-moz-file" is assigned if you dnd the xml image (a tmp file is created).  dnd urls  onto folderpane wfm, with this patch.
Comment 17 alta88 2012-02-15 11:45:45 PST
Created attachment 597505 [details] [diff] [review]
patch


this updated patch handles the image link dnd case, as well as fixing the data transfer type to get the url only.
Comment 18 alta88 2012-02-15 11:47:21 PST
*** Bug 516929 has been marked as a duplicate of this bug. ***
Comment 19 alta88 2012-02-15 11:48:28 PST
*** Bug 256777 has been marked as a duplicate of this bug. ***
Comment 20 alta88 2012-02-15 12:11:12 PST
*** Bug 613812 has been marked as a duplicate of this bug. ***
Comment 21 alta88 2012-02-15 12:13:22 PST
*** Bug 383633 has been marked as a duplicate of this bug. ***
Comment 22 David :Bienvenu 2012-02-15 15:16:02 PST
Comment on attachment 597505 [details] [diff] [review]
patch

thx, that works for me.
Comment 23 alta88 2012-02-15 18:41:04 PST
*** Bug 358648 has been marked as a duplicate of this bug. ***
Comment 24 Mark Banner (:standard8) (afk until 26th July) 2012-02-21 05:30:09 PST
Checked in: http://hg.mozilla.org/comm-central/rev/74aecd7c865c

Note You need to log in before you can comment on or make changes to this bug.