Closed Bug 517518 Opened 11 years ago Closed 11 years ago

panning left always brings in the titlebar

Categories

(Firefox for Android Graveyard :: Panning/Zooming, defect)

x86
macOS
defect
Not set

Tracking

(fennec1.0+)

VERIFIED FIXED
fennec1.0b4
Tracking Status
fennec 1.0+ ---

People

(Reporter: madhava, Assigned: stechz)

Details

(Keywords: regression)

Attachments

(1 file)

nightly build of 2009-09-18

When I'm zoomed in, and nowhere near a sidebar, panning to the left (i.e. panning to see what's to the left; the page moves to the right) brings up the titlebar.  This shouldn't happen.
tracking-fennec: --- → ?
Assignee: nobody → webapps
tracking-fennec: ? → 1.0+
Keywords: regression
Flags: wanted-fennec1.0?
Calculating the pan away sidebars amount was returning small fractional values.  Content scrollBy would not do anything for values less than 1.  The sidebar would then scroll by a pixel before content would start moving, causing the URL bar to show.  Rounding the pan away amount fixes the problem.
Attachment #401938 - Flags: review?(mark.finkle)
Attachment #401938 - Attachment is patch: true
Attachment #401938 - Attachment mime type: application/octet-stream → text/plain
Comment on attachment 401938 [details] [diff] [review]
Round calculation for panning sidebar away

Was talking with Ben about this earlier.  This looks like a good fix to me, and works in my desktop build.
Attachment #401938 - Flags: review+
Attachment #401938 - Flags: review?(mark.finkle) → review+
pushed:
https://hg.mozilla.org/mobile-browser/rev/6804d689e10f
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Target Milestone: --- → B4
verified FIXED on builds:

Mozilla/5.0 (Windows; U; WindowsCE 5.2; en-US; rv:1.9.2a2pre) Gecko/20090922 Fennec/1.0a3

and

Mozilla/5.0 (X11; U; Linux armv6l; en-US; rv:1.9.2a2pre) Gecko/20090922
Fennec/1.0b4pre
Status: RESOLVED → VERIFIED
Flags: wanted-fennec1.0?
Component: General → Panning/Zooming
You need to log in before you can comment on or make changes to this bug.