If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

glwrap.cpp: glxext.h: "GLboolean has not been declared" when building with nvidia drivers

RESOLVED FIXED

Status

()

Core
Canvas: 2D
--
major
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: BenB, Assigned: smaug)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
Environment:
- suse 10.3
- nvidia (binary) driver 185.18.14

Reproction:
1. Check out Firefox tip
2. make -f client.mk build; make

Actual result:
../../../../source/content/canvas/src/glwrap.cpp:54:
/usr/include/GL/glxext.h:803: error: ‘GLboolean’ has not been declared

Expected result:
Builds without error


build output:
make[5]: Entering directory `/mnt/media/mozilla/firefox/trunk/debug/content/canvas/src'
glwrap.cpp
c++ -o glwrap.o -c -I../../../dist/system_wrappers -include ../../../../source/config/gcc_hidden.h -DUSE_GLX -DMOZILLA_INTERNAL_API -DOSTYPE=\"Linux2.6\" -DOSARCH=Linux -D_IMPL_NS_LAYOUT  -I../../../../source/content/canvas/src -I. -I../../../dist/include -I../../../dist/include/nsprpub  -I/mnt/media/mozilla/firefox/trunk/debug/dist/include/nspr -I/mnt/media/mozilla/firefox/trunk/debug/dist/include/nss      -I../../../../source/content/canvas/src/../../../layout/xul/base/src -I../../../../source/content/canvas/src/../../../layout/style -I../../../../source/content/canvas/src/../../../layout/generic -I../../../../source/content/canvas/src/../../base/src -I../../../../source/content/canvas/src/../../html/content/src   -fPIC  -fno-rtti -fno-exceptions -Wall -Wpointer-arith -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -Wcast-align -Wno-invalid-offsetof -Wno-long-long -pedantic -fno-strict-aliasing -fshort-wchar -pthread -pipe  -DDEBUG -D_DEBUG -DDEBUG_ben -DTRACING -g -fno-inline -I/mnt/media/mozilla/firefox/trunk/debug/dist/include/cairo -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/freetype2 -I/usr/include/libpng12 -I/usr/include/gtk-unix-print-2.0     -DMOZILLA_CLIENT -include ../../../mozilla-config.h -Wp,-MD,.deps/glwrap.pp ../../../../source/content/canvas/src/glwrap.cpp
In file included from /usr/include/GL/glx.h:350,
                 from ../../../../source/content/canvas/src/glwrap.cpp:54:
/usr/include/GL/glxext.h:803: error: ‘GLboolean’ has not been declared


mozconfig:
. $topsrcdir/browser/config/mozconfig
ac_add_options --disable-profilesharing
ac_add_options --disable-profilelocking
ac_add_options --disable-system-cairo
ac_add_options --disable-updater
ac_add_options --enable-xinerama
ac_add_options --disable-oji
ac_add_options --disable-gnome-vfs
ac_add_options --disable-gnomeui
ac_add_options --disable-crashreporter
#ac_add_options --enable-application=composer
#ac_add_options --enable-composer
ac_add_options --disable-optimize
ac_add_options --enable-debug
#ac_add_options --enable-optimize=-Os
#ac_add_options --disable-debug
ac_add_options --disable-tests
#ac_add_options --enable-static --disable-shared
#ac_add_options --disable-static --enable-shared
#ac_add_options --enable-extensions=default,inspector

mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/../debug/


Last checkin on glwrap.cpp:
changeset:   32836:be2a05a9e4ef
user:        Vladimir Vukicevic <vladimir@pobox.com>
date:        Thu Sep 17 23:01:12 2009 -0700
summary:     b=516213; Freshen WebGL implementation and enable on trunk (part 2); r=mwsteele,roc
(Reporter)

Comment 1

8 years ago
Workaround: --disable-webgl , but that just triggers bug 517612.

Ergo: Can't build Firefox.
Summary: glxext.h: "GLboolean has not been declared" when building glwrap.cpp with nvidia drivers → glwrap.cpp: glxext.h: "GLboolean has not been declared" when building with nvidia drivers

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 517566
(Reporter)

Comment 3

8 years ago
Why did you dup this? The other bug starts with "machine without hardware accelerated graphics". I do have GLX.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Comment 4

8 years ago
Ben,
Sorry about the wrong dupe. You're right. This was mentioned in bug 516213 before you filed. A fix for older distributions was pushed at the same time you filed this bug. I mentioned this to you on IRC before duping but you didn't respond. Can you try again and close if this is fixed?
(Reporter)

Comment 5

8 years ago
> I mentioned this to you on IRC before duping but you didn't respond.

You mentioned it after you duped and I reopened, and I was already gone.

> [in bug 516213 comment 8] A fix for older distributions was pushed

Great, I'll try that, thanks!
Depends on: 516213
(Reporter)

Comment 6

8 years ago
FYI, my GL headers come from nvidia (see initial description), not from suse 10.3 (mesa). The nvidia binary driver installer installs them and the glext.h in question has a "Copyright NVIDIA Corporation".
(Reporter)

Comment 7

8 years ago
Apparently fixed with bug 516213 comment 8 by smaug. Reassinging to patch author and marking FIXED.
However, I am not sure this is the right fix: I'd be surprised if nvidia drivers were "legacy GL".
Assignee: vladimir → Olli.Pettay
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.