No protection of browsing history

RESOLVED INVALID

Status

()

--
critical
RESOLVED INVALID
9 years ago
9 years ago

People

(Reporter: helenetoile, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.10) Gecko/2009042523 Linux Mint/7 (Gloria) Firefox/3.0.10
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.10) Gecko/2009042523 Linux Mint/7 (Gloria) Firefox/3.0.10

I currently use linux mint, and the problem was as so: 
I had too many tabs open and firefox crashed. Upon reopening the session, firefox reopened all tabs, but my sidebar history was completely empty. (Shortly prior to the crash, I had reset my history preference to 139 days.) 

This might be a bug.

About firefox in general: I have been using firefox exclusively for three years, during which my history was erased by various mechanisms at different times (windows xp, usually). Managing the history on firefox is the most difficult task on a computer: 
1. If you _want_ to delete several (but not all) items in a day's history, you must select them one at a time to remove them (that is, you cannot select them in groups using the ctrl or the shift key). This is a nice protection, 
2. If you _want_ to delete even one item, some items prove to be indeletable. BUT: 
3. If you or your computer _accidentally_ delete an item or an entire day in the history, there is no way to restore it. There is no "trash can" to dig it out of, there is no dialogue box "are you sure you want to delete this" -- it just disappears in a millisecond into thin air. 
Every other computer programme I use has one or both of these controls against accidental loss of info, except for firefox. This has cost me many a day of research. (I am going to back up daily from now on, but am very frustrated over the most recently lost data.) 

Reproducible: Didn't try

Steps to Reproduce:
1. Deletion of history seems to happen by different mechanisms, some more seemingly random than others.
2.
3.
Please create for each single issue a single bug report and don't put multiple issues in one report. Bugzilla is a tool for our developers to manage issues and fix them, putting more than one issue in one bug makes it impossible to use the bug report and that is the reason why I will mark this bug invalid.

Please create new bugs for each issue and put them for example in the Bookmarks&History component after you searched for existing bug reports.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
Also, before filing a bug, upgrade to Firefox 3.5.3 or later, and try to use an official Mozilla build
You need to log in before you can comment on or make changes to this bug.